Inverted Colors When Compositing

Does anyone else have this weird problem? If so, did it show up in one of the latest versions of Blender?

Very simple scene, just a sphere with a monochromatic Emission material, and a plane below. When I try to add glow and/or glare effects via the compositor (in the same way that’s worked before, per the Wow Factor’s instructions), I get this odd inverted color thing.

Is the “Screen” mix node now not the way to combine nodes/node effects?

P.S. The top “render layer” input is the plane, the bottom input is the sphere.

P.P.S. Odd; putting the screenshot in here counts as too many characters to upload. See attached image instead. (If it works…)

Attachments


I think if you mute the BrightContrast node, you might get back to normal expected output. I reproduced your setup without that node, and I got a very decent glowing orb

If the screen effect is exceeding 1.00 then you may have an illegal color issue.

Turn on Clamp then?

“Clamp” doesn’t seem to do anything.

After some more experimentation, I got this…


Maybe I’m missing something, but it seems that somewhere in one of the recent updates (2.69, 2.68a, etc…) that the “Mix” node is no longer necessary for combining a blur or glare of object with the original object.

That would make sense, I think, since most of the time one wouldn’t want just the blur or glare, but want the original shape/object as well.

Can anybody confirm or definitively refute the idea that the “Mix” node is now unneccessary for these effects?