Invisible haloes

Hi all,

I’m building a scene showing the sizes of several giant and supergiant stars. These are UVspheres with textures applied. They render beautifully.

As a sense of scale, I added a circle to represent Earth’s orbit. That worked fine, too.

And to drive home the sense of scale, I also want to add the Sun as a dot. I’m using a single vertex with a halo material. I can add the vertex, apply the material, and render… and only the spheres and the circle appear. No halo.

I can create a test scene with just a halo-ed vertex and render that with no problems. I’ve compared the settings (material, render, world) to this test scene to the other scene and I can’t find any differences. I even made sure that the “Halo” render button was set in the output/render layer window in Scene (F10).

Are there any settings I might be missing that would prevent a halo from rendering?

If nothing is immediately obvious, I can post the .blend file for someone to try out. But I wanted to skip that if there was something obvious I was missing.

Thanks!

Make sure that you don’t have it on a layer that is not rendering. You have to match up the layers next to the word SCENE on the renderlayers tab with the layers next to the word LAYER.

Could you post the .blend file so we can see what the problem is?

kinda off topic, but are you sure you want to use a single halo for the sun? if i were you, i’d make it a white sphere with a circular blend set to win so that it would look good from any view. then use rendernodes to blur the edges a bit and make it glowy.

I’ll try to post a pic in awhile

[edit] sorry don’t map it to win, i can’t remember what to map it to, it’s been awhile. i’ll show you when i figure it out

Thanks for the replies, guys.

Rambobaby: No, it’s definitely on the same layer as the other objects and the render layers are chosen the same as the other scenes in the same file.

Coalth: I definitely want it to appear as a luminous point with no size other than the glow. The other stars in the scene are 20-600 times larger than the Sun, so the Sun should show no size at all.

FadieZ: Here’s the blend file that contains 3 scenes (small dwarfs, large dwarfs, and giants and supergiants). The last one contains the problem vertex with halo called “sun dot”. (It’s positioned at the center of the green circle called “Earth orbit”.) I just realized I left the halo size ridiculously large in the version I’m uploading. Correct as needed.

http://putstuff.putfile.com/34670/3676015

Any help would be greatly appreciated!

Do you have the Halo button set for the render layer that it’s on? (the one on the renderlayers tab)

Here’s the effect I’m looking for. I did this post-process in CorelPaint. I’d definitely like to know why the halo isn’t rendering in Blender, but no hurry on finding a solution now.

Blender render: http://www.putfile.com/pic.php?img=4453379

Post-process: http://www.putfile.com/pic.php?img=4453382

Rambobaby: Yes, I have all the render buttons pushed. I checked that the suspect file has all of the same render settings as a test file where the halo vertex works. Could you take a look at the .blend file I posted and see if I missed anything?

Thanks again!

Is this what you were wanting? I did it via masking in the nodes compositor. It gets a bit too complex for me to explain without writing a book. You’re probably better off doing it with a ring and a track to constraint because it’s much quicker and easier to work with. I just wanted the challenge. Here’s the file back in case you want to use it but be aware that there are some artifacts present on the green ring due to the z-combine node.

http://uploader.polorix.net//files/89/star-comparison[1].blend

I don’t know why you couldn’t get the halos to work because all stars had a single material applied. I had to re link them. Also I modified the file to get it to do things my way.

Attachments