Invisible lights showing in my mirrors

For some odd reason the planes I made invisible is showing on the planes I made into a glass texture. Is this a bug or do I have to make sure the plane with the glass material doesn’t get diffuse. Im lost, please help me. :slight_smile:

to avoid that you have to uncheck “Glossy” under “Ray visibility”

you have to do that for the emitter, not for the target