Invisible Stuff in 3.2.0 Beta

20220513Startupblend.blend (1.1 MB)

That’s my 3.1.2 startup blend. When I open it in 3.2.0 beta (any of them, latest attempt on today’s) I can see the Default Cube, but neither Suzanne nor my Ground object are visible in Object mode (although they are visible in Edit mode):

I’ve verified they’re neither Hidden in the Viewport nor Disabled in the Viewport, and tried Shift-H / Alt-H a few times, didn’t help. I’ve tried with other blend files, same problem – only the Default Cube from the blend can be shown, although newly added objects show just fine. Have I found a bug, or am I just missing something?

This post to bring up the topic’s infobar.

Both the Plane (ground) & Suzanna appear visible to me without any changes when I open your uploaded blend file.

Blender 3.0 (official)

Blender 3.2 (UPBGE 0.3.2)


I think you forgot to set your custom blend as your Startup File in your Blender 3.2.0 beta version. You can do this by going to:

1 Like

If you look at my screenshot you’ll see that the file’s opened and both Suzanne and my Ground object show in the Outliner, but not in the Viewport. And I appreciate you testing this in 3.0 and the UPBGE, but you’re not showing that you’ve tried it in the latest Blender 3.2.0 beta from builder.blender.org/download/daily/, which is where I’m having the problem.

Looks like a bug to me, especially since it’s version specific. Since it’s a daily build you’re using, a bug report will probably get noticed and resolved a lot more quickly :slight_smile:

1 Like

Is it a bug happening to others? Or something I’m doing wrong? Is it a bug that’s been reported already? (I haven’t spotted it, but that doesn’t mean it’s not there).

I read the manifest fairly often, and I haven’t seen it reported. I don’t think it’s something you’re doing wrong, although it’s hard to say precisely, but it’s always worth a report. If it’s already been reported, they’ll just merge it

1 Like

I just downloaded the daily Blender 3.2 build from:

image

Opened your blend with no changes and everything appears normal. I’m using default factory settings as well.

Maybe it’s a operating system or graphics vendor issue.
I’m on Windows 11 Home with a NVIDIA GeForce RTX 3050 Ti Laptop GPU.

1 Like

Windows 10, AMD Radeon R5, an HP laptop. And, fiddling around with it, I just found that killing the subdivision made them both visible again. That reminded me of something I saw on StackExchange recently (“Go to Edit → Preferences → Viewport → Subdivision and disable GPU subdivision”), tried it, and it worked! It’s a known bug with AMD graphics cards.

Guys, thanks so much for helping with troubleshooting, really appreciate it!