IPOs not working in GE

Hi i’m new to the BGE, and I have a problem with the IPO’s in the game engine.

I’m making an fps and I have an animation for your initial weapon when you start the game. It is supposed to rotate from a position 45 degrees below to straight forward. When you use alt-a to view the animation, it works correctly, but when I play the game, it starts 45 degrees above the animation and rotates straight up, as if the whole thing is rotated 45 degrees upwards. I included the .blend file. you have to be in the camera view. Look at the ipo and compare it to the animation in-game. I would appreciate it a lot if someone could help me. :spin:


fpsworking.blend (423 KB)

Um ok that is really weird. I tried both and yes the animation seems to play backwards or something. I tried keyframing it again and now it just dissapears. I also noticed that once I edited it, the second I play the game it moves far away. Now, your logic bricks are set up to parent the sword like thing to the camera?