Is anti-aliasing getting in the way of pixelated style render?

This is the final render I’m trying to accomplish.

https://s3.postimg.org/ci7xev4en/final.jpg

I got here by doing the following steps:

  • Changed the resolution to 128x128 px
  • Turned off anti-aliasing
  • Turned on free style: line thickness -> absolute, line thickness -> 0.300 px
  • changed camera to ortho
  • added a torus
  • mouse wheel zoom into the 128x128px rendered image.

When I render, the image is the expected 128x128, and when I zoom in with the mouse wheel, I make the image bigger and get that final result I showed above.

I’d like to scale it up in the compositor, but when I do I get this:

https://s21.postimg.org/re2e8k803/why.jpg

Like if anti-aliasing was still on, but I turned it off. I’m not sure how to scale it up correctly with the compositor so it looks like the final result above. I’m very sure some internal anti-aliasing is happening when I’m scaling, but I’d love to turn it off if that’s the case. :frowning:

Turn off Mip Mapping in the Preferences, System tab.

Not sure if I’m doing it wrong, but even if I turn off Mip Mapping, I still get a blurry image.

https://s10.postimg.org/w1yev5fjp/stillnotworking.jpg

The scale node does its own resampling, but for whatever reasons you can’t choose which filter to use.

Use Transform node instead and select Nearest as the resampling filter.

Hey thanks, that did the trick :slight_smile: