is anyone getting this bug (CVS)?

When trying to launch a script from the menus, if the .py resides in a subfolder inside the scripts folder… it wont run (ie: scripts/mariano/
Error message in the console:
Error loading script: couldn’t open file C:\Archivos de programa\Blender Foundation\Blender.blender\scripts\c:\mariano\
I have and spanish Windows XP… with the “Archivos de programa” folder instead of “Program files”
Can please anyone confirm this bug? It happens with all latest CVS

000283 build english graphicall confirm error. selection state error (script worked up until save object.)
also discombobulator broken,
tested bevel center ok.

Bevel center works? odd…
I have to report this bug… thanks for the help testing

subfolders arnt supported. no scripts should be in a subdir.

ok… but the error message this throws doen’t seem very elegant.
shouldn’t the scripts in subfolders remain undetected by the menues then?
really, I dont see this change as an improvement.
just my two cents.

My 50cents worth.
no subfolders means i will have to have 200+scripts in one directory?
what is the purpose of this?:confused:
i always place add on scripts into subfolders to keep directories clean
& managable, I even go through the bundled scripts and move them into directories.:slight_smile: some scripts only work from or with sub dir/folder.
I and others have scripts in a ordered folder that can be pasted between blender builds for ease of use and testing.
I would have thought it would have been better to:
A/ keep/have support for sub folders/dirs
B/ have subfolders for each Script Menu Catagory as default anyway including a directory for extra or add on scripts. (includes A )
ie: Folder for each catagory.

I hope this is only a problem in the cvs builds and not for the next release.
Sure, I will work round it but how many scripts will suffer that require subdirs.
Or will the auto installer fix this?

The old saying ‘If it ain’t broke don’t fix it’ comes to mind.

There was/is nothing wrong with the current system of installing scripts as it is comparatable to the way you would install many scripts in many professional programs.
Many pshop scripts don’t come with an installer, same with gimp. You paste them into the plugins/scripts folder, often into a subfolder to prevent clashes or to keep your folders organised. Max and Maya, most times there is an actual installer as most scripts/pluggins are propriety software.
Not that I am against a script installer for blender, I like that idea, but I also love the freedom i have to add and remove scripts at will already.:slight_smile:

Edit> not an installer problem.

Also the subdir possible problem doesn’t explain why discombobulator didn’t work.
as it resides in the main script dir anyway.

I did however reproduce Mariano’s bug exactly with several other well known scripts.

In truth, blender’s script directory is a mess of unorganized text files that is hard to browse, ugly to look at and unprofessional in it’s layout.

Sorry about the passionate rant. Not everyone is a ‘script power user’ like me.:rolleyes:


As far as I know there not supported, and never were.
the way you can have 200+ other scripts is by having a “User Scripts Dir”
see the path preferences.

that’s fair enough cambo, normally I do paste several folders into .blender/scripts.
without issue.
In the build I am using recent cvs this does not work.
I get the same error as Mariano for all added scripts in my folder called extras.
With the particle patch several inbuilt (bundled) scripts are broken with multiple errors.
I did get discombobulator to work if you uncheck copy object before modifying.
I have tested this with 000283_blender_sfx and 000354_blender_particle_070101 pasted into 2.42a. Both builds return similar errors. Next I will try to locate the actual .dll that is causing the problem if I can.

So in quick summary so far,
In Blender 2.42a I can create folders in .blender/scripts and move or paste scripts freely, update menus and they all work.
In current cvs builds this is no longer possible. at all. Even if I do set the default python script directory.
I can in the cvs builds paste scripts into .blender/scripts and they work unless like blender library script they need an or look for a directory.

Something has changed.

Thanks, M.A.

Scripts in subfolders was ALWAYS supported… Many scripters around distribute his stuff in a packed subfolder (gen3 for example). I did some research in older builds and this got broken when the extra IMAGE scripts category was added.
This is an error… a minor bug caused by some modifications in the core code. Needs to be reported and get fixed, thats why I did. God knows what extra errors this is causing in scripts.