Is continuous particle generation possible? v2.44)

I’m trying to create a very dusty, windblown atmosphere using my ground-plane mesh as a emitter, but am having probs with the particles clearing the rendered areas of the scene. This is due mainly to two issues: the particles count is limited to 100,000 (sounds like it should be enough, but not for a relatively wide expanse of dusty plains), and there is no way to have a mesh continue to emit after the count has been reached, even though some particles may have died. This is because they are emitted over a range of frames rather than on a per-frame basis. The range can be tweaked to keep the majority of particles in view for a single camera, but to cover a large area with multiple viewpoints (and still have some continuity in the effect), I’ve found it necessary to put eight(!) high-density emitters in my scene, which really drags down render time and took many hours to set up. It should be possible to achieve similar effects with many fewer emitters (perhaps even one).

In order to have the scene ready for the first frame, I have to put a -250f start on the particle effects, so a lot of particles are emitted prior to the first frame render, and the forces (wind) begin shoving them out of the effective view. During the passage of the rendered frames, the remaining particles are emitted and also begin leaving the scene. Once the count is reached, no more particles are generated, and as the emitted particle cloud drifts in the wind, it leaves areas of the scene clear of particles (see pics, top and side orthos of the particle clouds and the emitting ground planes, at first and last frames rendered). Note how the particles of the unselected emitter (black) drift completely off the generating plane.

The area outlined in cyan is the only part of the scene where rendered action takes place, btw.

With a single mesh emitter, with pre-rendering and even very long lifetimes and end frames, 100k still doesn’t provide enough particle density to cover a large area of a scene and keep pumping out particles through a 410f sequence. By using multiple emitters with different specs (determined by lots of tweak-and-test-renders), I’ve been able to get better results but at the price of a lot of render time.

In game level design emitters have the option of a particles-per-unit-time setting, and the same emitter continously pumps put particles at the set rate. Total particle count is limited by lifetimes and pre-set limits. This would be extremely useful in Blender as well, with a particles-per-frame setting allowing a mesh to emit continuously during any length of frames, with the total count being maintained by a balance of particle birth and death. No gaps would form as particles are moved because they’d be continuously regenerated by the mesh over its entire area.

I was also a bit surprised at the behavior of child particles – seems the forces in play are added to the child, along with the already-applied parent forces. In my windy scene, child particles zip off at twice the speed of the initial generation! Is this intentional? Is there some way to modify this behavior? It seems somewhat limiting.