Is dynamic indirect lighting possible with Eevee?

I mean, if I don’t use use an irradiance volume, things are usually very dark. But if I use it, indirect lighting seems static. Even if I move a thing that reflected the light, the light is still there.

So, what I wonder is, is dynamic indirect lighting (even if it is not very accurate) possible with Eevee? Or do I have to use Cycles if I want dynamic indirect lighting?

At this time, there is no way to do it in the main version of Blender, irradiance volumes are indeed static. However, there is a modified (unofficial) version of Blender you can download called “eevee screen space global illumination”. This adds realtime indirect light to Eevee, but it can only use what is visible on screen, so it won’t work in every scene.

An other alternative that could work is using manually placed and animated lamps to fake indirect lighting.

Hey, There is an addon called Eeevee Dynamic Lighting before. It basically will bake for each frame for animation render. So when object move in different frames, it will updated too.
If i’m not wrong, it is in sale 50% off now.

Just bought and tried. This moment adds only buttons and frame preview to the free script! :frowning:

I already purchase this addon and I guess you don’t understand the purpose of this addon. It’s not ONLY adds button and frame preview. The main use of this addon is to bake irradiance volume per frame when rendering animation which you can’t do with normal blender except baking it 1 by 1 per frame.

You can’t see the difference if light and emission shader in your scene is static. That is why it’s called dynamic.

You guessed wrong. I Know well the purpose of this addon. But in ver.3.0, once started the animation render, you could be able to stop it just ending the whole program (think of have started rendering a range of 250 frames…). CTRL+C (or BREAK) on Win didn’t work for me. Had always to go through Task manager, and restart the whole thing. More, the addon didn’t read the STEP FRAME value in Scene Tab.
I asked the author to upgrade with these simply mods, and the guy did it fast as hell!! Now it HAS these important (almost for me) features (Ver 3.1)

Is this still an issue, no plans to resolve it in any upcoming versions of Blender? It’s a pretty nasty limitation for most people doing animation in Eevee: You can only have irradiance with static lights, any light that moves or is toggled at a given frame just can’t contribute to the effect.

A simple solution I assume could be implemented immediately is a checkbox for irradiance volume objects, indicating you want them to be baked each frame before rendering, rather than universally from the Render menu. It shouldn’t require massive changes to how they work: Blender just needs to selectively trigger a new bake as you go through frames. We could even detect when an acting light or object has moved in the volume and skip baking again when no update is needed!

Is there any reason such a system cannot be considered? I’m tempted to suggest this on the bug tracker, not sure if others have already and I might pointlessly annoy with an obvious suggestion.

I do not think there has been any change to this. I am using the 3.0 alpha version, and I see no dynamic indirect lighting option. One thing I have noticed is that if I enable Auto Bake, the light gets updated each time I the irradiance cube. Using that as a hint, I set a minimal rotation animation (for the sake of “change” to trigger auto-bake) to the irradiation cube, and a wide move animation to the light-emitting object, and jumped to random frames manually. The indirect light did get updated, but this only worked for manual frame jumping in the viewport, not in the animation render, or when I press the play button in the viewport.

Hello, I just bought the Eevee Dynamic Lighting addon, and it is just what I need but I have one problem I can’t solve:
I hit the ‘Animation render’ button and it renders only the first frame of the animation.
I tested on a simple scene, only a plane, a cube and an irradiance volume, it worked. The addon rendered the animation.
But when I opened a more complex scene (archviz interior with several lights and 3 irradiance volumes) I can only render the first frame.
I sent a message to the developer but so far no replies.

Doens anyone know something I should do?

Hi Abrahim!
The dev is here :). We are sorry for this inconvenience.
It is a common problem. The solution is that the file output name should be empty. Or else it will only render one frame. If you still encounter the issue, please don’t hesitate to reach us directly.
For the detail, we attach the image below

This is the output path - it shouldn’t be empty

This is the file output name - it should be empty