Is install_deps.sh broken again?

Just tried it on a fresh Ubuntu 18.04 and it won’t compile Opensubdiv.

Scanning dependencies of target osd_dynamic_gpu make[2]: *** No rule to make target '/usr/lib/x86_64-linux-gnu/libGL.so', needed by 'lib/libosdGPU.so.3.3.3'. Stop. make[2]: *** Waiting for unfinished jobs.... [ 98%] Building CXX object opensubdiv/CMakeFiles/osd_dynamic_gpu.dir/version.cpp.o CMakeFiles/Makefile2:258: recipe for target 'opensubdiv/CMakeFiles/osd_dynamic_gpu.dir/all' failed make[1]: *** [opensubdiv/CMakeFiles/osd_dynamic_gpu.dir/all] Error 2 Makefile:140: recipe for target 'all' failed make: *** [all] Error 2 ERROR! OpenSubdiv-3.3.3 failed to compile, exiting

[email protected]:~> dpkg-query -S /usr/lib/x86_64-linux-gnu/libGL.so
libglvnd-dev:amd64: /usr/lib/x86_64-linux-gnu/libGL.so

That’s the package you’re missing.

I would recommend doing

apt-get build-dep blender

as a starting point – that should grab most of the dependencies, at least for older Blender versions.

Thanks for your answer. But no liGL was not installed. I solved it by compiling Opensubdiv manually.

By the way, it seems the OpenSubdiv build scripts explicitly require Python 2.6 for generating the documentation. I posted a patch so the scripts run with Python 3.x instead.