Is the Navigation/Orbit Gizmo broken in the released 2.8?

I have been working with on of the Beta 2.8 releases. When the Stable 2.8 was released at the end of July I downloaded and installed it. I just now got to working with it and I discovered the navigation gizmos in the upper right are not working. I can use the keypad to select axis views and change the Perspective view. But clicking on any of the upper left icons no longer works.I cannot grab the X, Y, or Z navigation icons to move them. I cannot click on the Axis indicators to change the view and clicking on the Perspective icon does nothing.

I know this worked in the beta release in July. Has something broken, or has a setting change that I need to adjust?

I cannot beleve that something this obvious could have gotten past the Beata testers.


Sorry - I meant the UPPER RIGHT when I said UPPER LEFT.

It’s working as intended for me. Maybe try going back to factory defaults?

Tried teh factory settings - no change.

Ok - I don’t know what the issue was but I got it fixed. I tried going back to factory defaults but that did not work.

When I first loaded the 2.8 Stable release I used the MSI file to do the load. This time I downloaded the ZIP file and extracted it to my Programs/Blender folder over the existing installed and now my Navigation Gizmos work.

1 Like