Is there a trick to get overall even lighting?

Since Cycles takes too long for me to render (cpu only and I haven’t worked too much with LuxRender either to see if that one would be quicker) I have to use the BI renderer. I’m having issues getting even lighting. I’ve tried area lights in a 3 point light set up either I’m getting those settings wrong or missing something in them.

See, I make microstock images and they like even lighting with no noise are artifacts. I’m not sure how much of that I can get away with (course I haven’t really tried to submit anything that would have noise in it).

Is there a setting in Blender that could help me achieve that or do I really need to have more than 3 lights in a scene? I don’t have a blend file ready to upload to explain my issue better. I struggle with lighting a lot.

Thanks :slight_smile:

You could try turning on environment lighting in the world tab

Thanks so far that’s done the trick :slight_smile:

No problem, glad to help