Is there a way to force bleder to re-build/compile the cuda stuff?

The what: cuda 2.80 crashes when using GPU compute and selecting CPU&GPU combined in the settings>preferences.

kernel: [ 3022.024169] NVRM: GPU at PCI:0000:43:00: GPU-49d0fc55-2a22-a0ed-20ec-6ef3b3d43ca4
Jan 3 13:42:50 BusterTR4 kernel: [ 3022.024176] NVRM: Xid (PCI:0000:43:00): 13, pid=1213, Graphics SM Warp Exception on (GPC 3, TPC 0): Out Of Range Address
Jan 3 13:42:50 BusterTR4 kernel: [ 3022.024183] NVRM: Xid (PCI:0000:43:00): 13, pid=1213, Graphics Exception: ESR 0x51c648=0x8000e 0x51c650=0x0 0x51c644=0xd3eff2 0x51c64c=0x7f
Jan 3 13:42:50 BusterTR4 kernel: [ 3022.024377] NVRM: Xid (PCI:0000:43:00): 13, pid=1213, Graphics Exception: ChID 0023, Class 0000b1c0, Offset 00001b0c, Data 00000000

(Edited to add: Although the log entries have BusterTR4, I have not got around to changing the hostname yet which is why that says that.)

The when: Setting cuda compute in preferences to GPU works fine, and setting cuda compute preferences to CPU also works fine. But setting both causes the gpu to render tiles (for a while) while the CPU tiles just seem to sit there full of dots while doing nothing. Eventually even the GPU tiles stop progressing and the whole thing grinds to a halt with the kernel error messages.

Occasionally in the past if I’ve had cuda issues where cuda crashes and then refuses to work, but closing and re-opening blender usually solved the issues. This time however it does not.

Also as I’m running debian testing there are often lots of updates going on, including kernel and kernel-nvida packages, and so I’d like to set the blender cuda environment “clean” so that when I try to run a cuda render it performs the “creating/compiling cuda kernel, this may take a couple of mins” from scratch. Basically force a first run cuda render just in case its some cuda kernel, linux kernel, nvidia driver versioning mishmash that is causing this. It did work fine with debian buster/stable but I had to upgrade to testing to get something else working and its since gone kerflewy!

Does anyone know if this is possible, and if so how to do it? I cant see any option in blender to “start clean”, so I’m guessing its some file that needs deleting so blender can re-create it.

Any help would be much appreciated.