Is there any way to straighten these verts


Is there any way to straighten top 7 verts of cylinder perfectly like as if it they were rotated 60 Degrees or so.

  • I can’t rotate as it ruins the symmetry of edges
  • I tried using other a plane as “stencil” rotate it at desired angle and snap to face, but doesn’t work
  • The only way I know is set up a plane…rotate at desired angle and subdivide it Gazillion times and use its edges as snappers, then move the verts of cylinder constrained to one axis.

Is there any better way of doing this ?

  • The only way I know is set up a plane…rotate at desired angle and subdivide it Gazillion times and use its edges as snappers, then move the verts of cylinder constrained to one axis.
    You could use the Knife Project tool to use this rotated edge to cut the object

Demo: http://screencast.com/t/rgbtaMICvlG8

If you wanted a 45 degree cut you could just use the knife tool with angle constraint enabled ©

Select all the verts you want moved, make the bottom vertex active and scale to zero in the appropriate axis with pivot set to ‘active element’. Your screenshot is cropped so can’t tell which one that would be.

(Edit: Just read Richard’s answer and it seems as if I have greatly underestimated the complexity of what you are trying to do!)

There is another way using Loop Tools addon.

Many thanks to all of you guys…for your help.

And thanks rambo for getting me aware of loop tools…I was looking for something exactly like that …never knew it existed…

you guys are awesome.

DruBan’s answer is not that far away. Could straighten them along an axis and then use shear to get the proper angle


Top left: starting point
Top right: active element pivot (alt+period), scaling to 0 along X
Bottom: shear (ctrl+alt+shift+S)


Bsurface Gstrech and 1D_scripts > Spread loop

there is a script to align verts between first and last point

alignpoints / StraightenPlus /

https://github.com/sftd/blender-addons-

happy bl

Or extend edges(green) then knife cut using endpoints as guide(red):

This is weird that there are so many ways…I knew none…but thanks for the same.

@ Richard

I’m having little trouble with using knife project…the if I try to cut a cylinder with a plane in orthographic views(Right and Left) , it doesn’t cut all the way through, i.e the polygons that are away from me remain unchangeed, I tried in wireframe, again no luck.

Any fix for that, help much appreciated

Enable cut through option from the operator panel

Again Thanks buddy…much appreciated