Is there anyway to stop clothes from going through model's body?

I’m making a low-poly model for a game (only around 1,000 - 2,000 tris/polygons) I’m making on unity, but I’m having problems with rigging the clothes, they’re always going through the player itself, it doesn’t make a different how much I play with the vertices or weight paint, there’s always a pose I make him do that makes the clothes go through the body.

I’ve made sure nothing had the armature applied twice and none of them had “Bone Envelopes” ticked, and none of them do.

Clicking on “preserve volume” on the Armature mods for the clothes helps a bit, but the clothes still sometimes go through the body.

Is there a method to make sure the clothes will never go through the body, that also works with Unity?

So there isn’t anyway to do this?

You could try creating corrective shape keys for the clothes (create basis shape key and one more, select the new one, sculpt with posed mesh) and then using for the poses that don’t work. As for ‘never’? I don’t know. Maybe some clever use of a (or several) floor constraints? I doubt that will work in unity though. Maybe you should ask over there instead! :stuck_out_tongue:

1: you could use a mask modifier using a inverted vertex group of the skin under the clothes thus hiding the skin and vastly reducing the problem. the fastest solution.

2: you could ensure the clothing mesh is weight painted in exactly the same way as the skin with matching edge loops and mesh complexity, thus making the deformed cloth match the skin exactly, and therefore removing any clipping, a time consuming option as weight painting is a pain imo… but once its done, its done.

3: you could use a cloth modifier,this would be the best looking option I can think of, at least in most situations, but would also take a long time to process and would take a lot of tweaking to get a good result.

4: a shrinkwrap modifier could hold the clothing with a fixed offset…

those’re some options :slight_smile:

things to keep in mind… cloth slipping is usually caused/made worse by badly matching topology on the two meshes and/or bad weight painting… two different meshes with much the same topology shouldn’t clip too badly if the weight painting is done well. Its a good idea to try to make the meshes similar, I often start making clothes by cutting up a duplicate of the skin mesh… this means I can edit the clothing whilst keeping the topology much the same.

1 Like