Is this a bug? Hair not rendered with CPU but with GPU

Dear Forum,

I encountered a very strange behaviour (of Blender 2.72b with Cycles): when I select CPU as rendering device, the hair is not rendered correctly. It seems it is being rendered with length of zero.
However, when I turn on GPU the rendering works correctly.
I deleted the girl and every other stuff from the scene, created a UV sphere, put hair on it, and it behaves the same. But when I open a completely new scene the hair rendering is correct with CPU and GPU.
So it seem this special file contains something that prevents the CPU renderer from working correctly.
But I have no clue what it could be.

Any suggestions are welcome.



But I have no clue what it could be.
You don’t help by not including in your post a blend file that shows this behaviour

Any suggestions are welcome.
Supply a blend file


>You don’t help by not including in your post a blend file that shows this behaviour

Well, I thought it might have been something trivial.
Here are some more infos about my system:

Windows 8.1 Pro, 64 bit
Intel Core i7-4770
NVIDIA GeForce GTX 750 Ti

On this system the attached file hair_bug.blend shows this error. With CPU rendering the hair is (almost) non-existent, with GPU rendering it is OK.

Thanks so far,



hair_bug.blend (971 KB)

Another information: I just rendered the test file on a computer which doesn’t have a GPU. Here everything is OK.


Can’t confirm this… Render results from your file:

Blender “official” 2.72b, see my signature for system details.

Intel Core i7-4770

Seems that you stumbled across a known issue with the Haswell cpu’s. There is already a bug report around where a Haswell CPU refuses to render a particle carpet in a proper way. cannot hurt to write a bug report about it. When it’s the same then the reports can be merged, and we have one more who is able to reproduce the issue.

Indeed. I opened an official bug report ( ) and got the following informations:

>It’s indeed a duplicate of T41066, you have a CPU with AVX 2 support, and the other CPU then does not.
>Closed a duplicate of this report. If it’s difficult to find a fix for this I would suggest to just disable the AVX 2 kernel for now, it’s better to have a working kernel than a slightly faster kernel.

The case is closed now and the email came from noreply… but there is still one thing I want to answer: instead of removing this feature why not include a switch so the users can turn it on or off?