Is this a bug?

I’m not that well versed in Blender so it might be something obvious that I’m missing. Still I consider this pretty strange though. I used 2.37a and 2.40 and both have the same behaviour (I don’t call it a bug yet, you see? :slight_smile: ).

I created a Mesh-Cylinder with 32 vertices. Then, in vertex mode, I selected the top vertices and pressed E -> Region and extruded the set upwards a bit, to make the cylinder longer. I did this several times, so I got 5 set of vertex rings between the ends of the cylinder. The I selected the ring in the middle and pressed S to scale the ring and make it larger. Now when I switched back into model view, this is kind of strange. Because the model looks continous as long as the scaling is small enough that the angle between on set of vertices and the next one is not to steep. As soon as the angle gets to steep, the model suddenly get’s holes and a single flat line where the vertex ring is located.

I created a series of screenshots to document what I mean.

This is what I created:
http://img413.imageshack.us/img413/1171/continuosvertexmode7wc.th.jpg

An this is how it looks (pretty much as you would expect it to):
http://img413.imageshack.us/img413/1559/continuosmodelmode1dz.th.jpg

Then I scaled the middle set of vertices:
http://img413.imageshack.us/img413/2079/scaledvertexmode7cx.th.jpg
and got this (still as I would expect it):
http://img413.imageshack.us/img413/2773/scaledmodelmode1ii.th.jpg

But now when I scale it even more:
http://img413.imageshack.us/img413/4672/scalederrorvertexmode12ua.th.jpg
Then this happens (which is not what I would expect):
http://img413.imageshack.us/img413/6271/scalederrormodelmode15rp.th.jpg

And when I scale it even more:
http://img413.imageshack.us/img413/6024/scalederrorvertexmode23cm.th.jpg
Then this is the result:
http://img413.imageshack.us/img413/219/scalederrormodelmode22av.th.jpg

The model looks like this in all views, so it seems to be not only a glitch in the window. I’m using an ATI Radeon 9800XT with a rather new set of drivers.

What I try to achieve is this I want to create the feet of the stool. If there is a better way to achieve this I would be pleased to hear about it. From Maye I know that you can draw a spline and then create a rotational object or another method is to create moltuiple splines and then the object is generated by following them. I don’t know if this exists in Blender as well because I tried to search for something similar, but haven’t found anything.

I’m not sure exactly what you’re doing wrong (or if it’s a bug) but I haven’t noticed any problems with it. I’d have to play with it to try to recreate your situation.

Edit: By the way, have you tried rendering to see if it’s a problem with the mesh, or just the way it’s showing in the 3D View?

Anyway, here’s the user manual section on how to create an object out of a curve profile.
http://mediawiki.blender.org/index.php/Manual/PartII/Basic_Mesh_Modelling

Just scroll down to the section on “Spin and SpinDup”, but if you’re new to Blender you might want to read the whole page (as well as much of the rest of the manual).

In Edit mode, in F9 buttons, in the MeshTools1 tab turn on “All Edges”. It’s not a bug, it’s a draw option.

%<

I don’t know what you can do wrong. I documented all the steps that I took, and this is as simple as it can get. I know that this worked in more recent versions, because I had another model with an equally steep angle, and I never encountered this problem before.

Edit: By the way, have you tried rendering to see if it’s a problem with the mesh, or just the way it’s showing in the 3D View?

I haven’t thought of that, but I tried it now, and rendering seems to be fine. Still it is annoying when you can’t see how the model flows. I would have to do a lot of prerenderings to see how it looks.

Just scroll down to the section on “Spin and SpinDup”, but if you’re new to Blender you might want to read the whole page (as well as much of the rest of the manual).

I will. :slight_smile: Thx!

I just noticed something with my setup which could be the reason for this. I’m trying to create some models for Doom 3. Normally, when I run Blender then I use a scale which is the default, but when I model for Doom3, I have to zoom out quite a lot, because the scale seems to be so big. Could this be the reason?

Read my previous post.

%<

I don’t know what you can do wrong. I documented all the steps that I took, and this is as simple as it can get. I know that this worked in more recent versions, because I had another model with an equally steep angle, and I never encountered this problem before.![/quote]

Sorry for the misunderstanding. What I meant was that I haven’t experienced the problem in Blender. I haven’t gotten around to following your steps to see if it happens for me.

I was wondering if this could be a problem with view clipping (thus my recommendation to render the scene). You can solve your problem by adjusting your view clipping settings to eliminate the problem. Clipping means, in case you don’t know, is the range nearest to and farthest away from a camera that will show up in the view. For the 3D Window it is set in the menu View->View Properties… For a camera object it is set in the edit buttons.

Edit: Or what Fligh % said, depending on the nature of your problem.

sparkhawk seems to be right .I tried to recreate his situation.U might think pressing the “all edges” button is the solution, but it is only as long as u don’t play with alt-Z, ctrl-Z and Shift-Z.Playing with this display modes seems to unpress the “all edges” button.That is; press the “all edges” button, play with the display modes and go back to the button;It has unpressed itself.
Note: the display is cut off only in wireframe mode.
Blender 2.40
P IV 2.6Ghz
1 GB RAM
radeon 9250, 256MB video
Win XP SP2