Is Time Remapping broken? Does it not work for VSE?

I created a Video Sequence Editor project at 30FPS, and I placed all of my strips and keyframes expecting 30FPS.

Now, the project is done, but I want to render it out as 20FPS video, at the same length and with the same animation timing as the 30FPS video.

From what I’m reading online, I should be able to accomplish this by setting, in Properties -> Dimensions:

FPS: 20

Time Remapping
Old: 30; New: 20

I have done this, and the ‘Time Remapping’ value seems to accomplish nothing. The video is indeed rendered out at 20FPS, but at 2/3 of the original speed, making the video a third longer.

Whether I render at 20FPS or 30FPS, regardless of the Time Remapping values, I get the same exact number of frames, and the frames at each frame number are identical across my tests (animations playing out over the same number of frames).

I have tried using Time Remapping to speed up the video (‘Old’ > ‘New’) and to slow it down (‘Old’ < ‘New’), and I’ve tried rendering as PNG images (my preference) and h.264 MP4 video (to make sure that the issue wasn’t related to PNG output).

Am I doing something wrong? Is this a bug? Does this feature not work with VSE strips? I appreciate your help.