Issue Making Particles Work with vertex groups

Pretty simple problem

Im modelling a feather. with particle feathers.

i create the stem simple geometry attached to a curve modifier. im currently using a cube, only scaled in edit mode along the y axis, then loop cut. i highlight the sides of the stem and create the vertex group.

create a particle system, and go down to the vertex groups. and set density to the vgroup.

what im expecting is that the hair strands only grow inside of the vertex group. but instead they grow on all sides of the area of the vertex group.

so if i select one face of the cube, the hairs grow ALL AROUND the cube. i have tried putting the assigned vgroup into all the boxes under the Vgroup tab. but still this remains.

is it a bug with bmesh or something? or am i missing a setting? i have tried messing with most if not all of the hair settings.

help would be much appreacieted

now im not sure which one specificly defines the ‘area’ of the particles. but im pretty sure its ‘density’

SOLVED: I went into weight Painting mode, and saw that my geometry was too simple, it caused the group to effect most of it, simply subdiving the mesh and working making a more seperated Vgroup worked.

edit: I definatly think there is something wrong with the particle system in 2.63

i have got it working 100 percent, if i i subdivide my mesh, then everything works well, hair comes out where it is supposed to,

but if i try and edit the shape of my mesh, or even edit it then redo the particle system. the particles come along the normals, and are near impossible to sort out with the particle comb and stuff.