Issue with Blender Cycles

I think the add-on Cycles Render Engine is causing the problem. Once the Cycles Render Engine installs and switching from Blender Render to Blender Cycles, the Blender closes. Is this add-on corrupted? It just happens today with I updated the drivers and windows patches.

Add-on? Cycles is pre installed. What version of Blender are you using?

The version is 2.79B

What add-on exactly are you installing?

Run Blender from a command prompt so you can see what if any error is being displayed as it closes.

You should not need to install any add-on beyond what comes bundled and enabled by default in order to use Cycles.

What video card are you using?

I don’t know on how to run a command prompt. I’m running Blender in a laptop. Nvidia Geforce MX150 is built in. A lot of my recent Blender files are saved in Cycles Render. When I open these files, Blender closes immediately. I have to remove the Add-ons files in Blender directory, so the Cycles Render is not installed, and I can able to load all the files. Blender is preventing me to use the Cycles Render.

Still not entirely sure what you mean, but have you tried simply re-installing Blender? It seems you may have deleted some files you shouldn’t have, and have corrupted your build perhaps?

I have uninstalled and reinstalled so many times. It seems the Cycles Render is the only issue ever since I updated drivers and patches in my laptop. Now, I have to use Blender Render to render all my scenes.

Since, I can not use Cycles Render. Is there a way to import all the shaders from Cycles Render to Blender Render?

Assuming this is Windows, you can click the Windows or Start button in the lower left corner and search for and run “Command Prompt”. Then you need to CD to the directory containing the blender.exe program, and type blender and hit enter and it should start Blender up. Any errors that get displayed will be output to the Command Prompt window.

Just switching the renderer to Cycles shouldn’t necessarily be affected by what GPU you have.

Also at the command prompt you can try executing:

blender --factory-startup

Which will bypass all your configuration settings and you can see if that makes a difference.

This is what I get.

Ok, so it’s crashing with an EXCEPTION_ACCESS_VIOLATION which it simply that something tried to access a bad memory address and so could be caused by just about anything.

Some things you might try could include trying a different version of the Nvidia drivers, or trying newer Blender version(s), either the latest 2.79 experimental build or even the 2.80 Beta, just to see if they encounter the same problem. They’re downloaded as Zip files and you can just extract them wherever it’s convenient and they won’t interfere with your existing install. Both can be downloaded from:

Thanks, 2.8 is working fine. How stable is 2.8? I heard good things about it?

2.80 is still in Beta probably a few months from official release. It changes daily and occasionally some instability might creep in for a bit until it gets fixed, but in general it’s been pretty stable lately. There are substantial changes made every day, so you should download a new version occasionally to keep up to date.

If you’re a fairly casual user then I would say it’s probably fine. If you’re doing heavy professional work then you’d want to be sure to evaluate whether its functionality is sufficient to do what you need at this point.