Issue with normal maps

I have a high-poly mesh (made with photogrammetry) which I’m trying to create a low-poly version of. The process I’m going through includes:

  • Create normal map and diffuse texture from high-poly version

  • Use an external software to re-topologise and create a low-poly mesh of the model

  • wrap low-poly mesh in normal map and diffuse texture from high-poly model

The issue I’m having is:

I’m not sure I’m doing this correctly, as when I look at the low-poly model (with normal map applied) it looks ‘blocky’ (see image)

Furthermore, I’m not sure if what I’m seeing (in the attachment) is actually the normal map. It appears grey, rather than the purple colour of the normal map texture.

I’m new to Blender so apologies if this question is basic. Any ideas welcome!


The blocky part of your screenshot is just the result of the retopo. Normal maps are part of the material, and you should be on ‘Material’ or ‘Rendered’ shading mode to see them. Right now it’s in ‘Solid’ shading wich only lets you see the geometry.
Also, a more typical way of doing this is to retopo first and do the textures on purpose for the retopo mesh (by baking from highpoly to lowpoly)

Yes, the usual way is to bake the high poly to the low poly. The normal map is a difference of the two surfaces, or in other words, how the low poly surface needs to change its appearance for it to look like the high poly. If you expect smooth results, both should be using smooth shading when baking. Button for smooth shading can be found on the tool shelf.

You have an object (object mode) that consists of object data (mesh, edit mode). Materials are assigned to the geometry. Materials have properties, in this case diffuse, specular, etc. because you’re using Blender Render. Those properties can be influenced with material assigned textures. When you have an image that is created for influencing a specific material property, it’s called a texture map. Commonly the map name tells you which property it is. For example diffuse map, specular map, alpha map, and others, including normal map.

UV map is the coordinates which textures can use to get the placement on the mesh itself. Those coordinates go hand in hand with the mesh, they’re part of object data.

Object and object data have corresponding properties in the properties editor, #5 and #8 http://getblended.org/screens/propertiesbuttons.jpg

The material you’re using needs to be assigned to the mesh faces in edit mode. First material goes on everything automatically, next ones you add need to be assigned manually. One material typically has more than one material assigned texture, so if you’re making a bumpy white material with a blue cross on it, you could add a diffuse texture map with blue cross on it to control the diffuse color, and second to make the surface appear bumpy, controlling the normals. The texture also needs to be set as normal map in texture properties -> image sampling, otherwise it interprets the image as a bump map when set to influence normals.

Multiple materials: http://getblended.org/screens/multiplematerials.jpeg
Material assigned texture: http://getblended.org/screens/materialuvtex.jpg but you can ignore the shown viewport shading settings. Use material viewport shading instead which shows material assigned image textures and shading, so you also need light in there
Normal map setup: http://getblended.org/screens/binormalmap.jpg

Thank you for your feedback. I was baking high to low-poly but as JA12 mentioned, both models (high and low) need to be smooth.

I eventually found that the software I was using for retopology was creating ‘sharp edges’. Selecting the retopologised model and clearing sharp edges got rid of the ‘blocky’ problem and left me with a smooth mesh.