Issues selecting the 3d manipulator arrows

So, without knowingly changing the settings, I opened up a fresh instance of Blender and found that I had a horrible problem! I can no longer select or use the 3d manipulator arrow widget!

Yes, I can, in fact, see the the arrow manipulator widget on the model, and that is what I’m referring to, not the minature colored axis reference points on the bottom left hand corner. It is enabled, set to Global, and yet, when I try to click on the arrows like I’ve always done, all it does is move the 3d cursor to the location instead of clicking on the arrows. I can right click on the selected face, and this will put it in a free translate mode (which I don’t want). Trying to right click on the arrows does the same thing. I’ve tried changing the widget to Local, normal, gimbal, and view, and none of them work. I’ve also tried the translate, scale, and rotate modes, and none of those work either. I’ve also tried resetting things to factory settings.

I can SEE the widget right there, and it seems to behave normally when you select multiple objects in that it does move to center itself. . . I just can’t interact with it.

I tried updating from Blender 2.61 to Blender 2.63 to see if that did anything, and it doesn’t. I still have the same issues in 2.63.

The only other things of note that happened is that in the last day or two, I did do the big windows update (running Win 7, 64-bit, professional), and I upgraded from Catalyst Control Center 12.3 to 12.6 (they really updated a lot in such a short span).

Can someone please help me in getting my arrows to work again? I know the short-cuts to move and scale things along the x,y,z axis, but being able to use the arrow widget saves me a TON of time, especially when I want to do multiple moves in a row.
:eek:

Update: I’ve tried changing the input for the 3D manipulator, and that doesn’t work either. I’ve also tried:

– Uninstalling and reinstalling Blender with all the config files removed (didn’t work)
– Restoring all of the default settings (didn’t work either)
– putting the 3D cursor on a different key (I still couldn’t interact with the 3D manipulator)
– Toggling between Normal, Local, Global, View, and Gimble modes (none of these modes worked either)
– Toggling between Rotate, scale and translate modes (They didn’t work either)

None of these things have worked. My 3D manipulator widget arrows are still unresponsive to anything I do.
I’d be incredibly grateful to anyone who knows how to fix them for me. I’m finding that I miss the nice precision work that the manipulator allows me to do. :frowning:

try the file menu load manufacture settings

this should reset all settings!

salutations

Have you set the pivot point to the 3d curser (period key on keyboard or dropdown list to the left of the widget controls on the 3d view header). Change it to median point or bounding box (comma key)

Scrysis,
I also have the same issue using the manipulator arrow widget in 2.65. It’s quite frustrating not being able to use them.
Did you have any luck finding a solution for this issue?
Thanks,
Bratteli

Try using the hotkeys G,S,R. It’s much faster/easier than the manipulator when you build the muscle memory; I can’t stand trying to click the widget perfectly and having to navigate my cursor to the bottom of the screen every time I want to do a different operation. Maybe it’s a sign from the Blender gods, lol. Either way, best of luck finding your solution.

Thank you dlax. It seems that my right button is not working for selecting object in Object Mode, and my left mouse button is not working for the manipulator arrows in Object Mode or Edit Mode, but works for things like vertex and edge selection in Edit Mode. I tried reinstallation of Blender without any luck. I might try to downgrade to a previous version of Blender to see if that helps. I probably would need some luck on this. :slight_smile:

I posted this question to two different blender forums, and actually did receive an answer on the second and a solution! (To mine at least.) The problem lies with the video card anti-aliasing settings and buffering. I had to turn it down to regular multi-sample AA without the extra buffering. I also set it on Narrow tent.

I’m not sure about Nvidia, but if you have a Radeon, you can adjust these settings for individual programs. Just go into Catalyst, go under gaming --> 3d settings. Once there, select a new set of settings, save for new application. It will ask you to select an application from your computer, which, in this case, is the Blender exe file. Once you do that, you can exit out of catalyst.

I have the hotkeys memorized, but if I want to move something just a little bit, or on one particular axis, the widget arrows are the best way to go.

Scrysis, thank for the post. I’ve been trying to figure this out also. In my case all of the handles on the widget worked EXCEPT for rotation on the Y axis. Very odd. When you mentioned editing GPU setting I checked to see which graphics processor Blender was running under, ended up being the integrated intel and not my nvidia hardware. Switched it over and problem solved. Completely forgot to check this.

WOOO - HOOOOOO! I was literally hitting my head on the desk!
I could not grab the visible edge of the rotate manipulators - Only (Get this) the invisible BACK EDGE of them!!?!?!
Changing my NVidia settings to force Blender to use the card fixed all.

THANK YOU!!!

Setting “Selection” in User Preferences System Tab from “Auto” to “OpenGL Select” made it for me (Blender 2.72).

Look, if on your right side menu (shortkey - “N”) -> View -> “Lock to Cursor” is marked. I unmarked it and got it fixed.

1 Like