Issues with Blender running under ubuntu 14.04

Since the last update by UBUNTU 14.04 I experience difficulties to run blender in a local folder (under home user).

Under linux, one has to install blender from the software center befor trying to run a more recent version of blender coming from the buildbot.

Once installed the package, one is able to run any new release placed under the home user folder, for me in the Downloads folder where I uncompress the tar package.

Until the laste update, two weeks ago, I had just to drag a link icone to the desktop to run blender.

Since two weeks ago, a new update from ubuntu has been released and is creating problems with the shortcuts and also with the activation of CUDA.

What is happening is first the shortcut don’t work anymore and no errors are logged in the system log, second when i run blender directly from the folder it is located in, CUDA services are not activated or showing in the user preferences.

To go around this, I did look for issues with rights and found out that if I log as sudo, then run blender, then I get the CUDA services activated. Otherwise, if I go in the latest release folder and try to run blender, I get it running but no way to get CUDA services.

I found out that first I have to sudo ./blender and it comes up normally with CUDA.
But then all the files I save as sudo are not accessible from my normal user logon. So what I have to do is to sudo ./blender, close it and then run it as normal user which provide me the CUDA services.

However if I shot down the machine, at reboot I have to redo the process, the state does not stay… somewhere there is a problem with the CUDA drivers, or the rights applied to it… Also the issue with the shortcuts not working is still an issue I have not been able to resolve and below you will find the log generated when I tried to run blender from the shortcut.

I have been looking at the ubuntu communities, support etc, and they are mentions of issues with the latest ubuntu update, but no specific blender solutions are provided.

I did these following tests from the terminal.

========================================================

[email protected]:~/Downloads/blender-2.73$ sudo ./blender
[sudo] password for yves:
connect failed: No such file or directory
Read new prefs: /home/yves/.config/blender/2.72/config/userpref.blend
found bundled python: /home/yves/Downloads/blender-2.73/2.72/python
fake_module: addon missing ‘bl_info’ gives bad performance!: ‘/home/yves/.config/blender/2.72/scripts/addons/overwmat.py’
fake_module: addon missing ‘bl_info’ gives bad performance!: ‘/home/yves/.config/blender/2.72/scripts/addons/removemat.py’
fake_module: addon missing ‘bl_info’ gives bad performance!: ‘/home/yves/.config/blender/2.72/scripts/addons/sendmat.py’
mesh_vertex_tools.py: new version loaded!

read blend: /media/yves/Workshop/Blender projects/Modeling/Haunted house/texture 2 3D from photo _01-03.blend

Error: Not freed memory blocks: 6

Blender quit
[email protected]:~/Downloads/blender-2.73$

Here CUDA is activated and I can access my paths as it should.

===================================
When trying to create a shortcut from blender folder to desktop blender show up briefly on the screen then bail out.

ERROR: apport (pid 3341) Mon Dec 22 18:39:40 2014: called for pid 3331, signal 6, core limit 0
ERROR: apport (pid 3341) Mon Dec 22 18:39:40 2014: executable: /home/yves/Downloads/blender-2.73/blender (command line “/home/yves/Desktop/Link\ to\ blender”)
ERROR: apport (pid 3341) Mon Dec 22 18:39:40 2014: executable does not belong to a package, ignoring

===================================
After I used to log as sudo, I can run directly by calling blender as ‘./blender’
If I close it and then open it again, no problem with CUDA or working with it.

[email protected]:~/Downloads/blender-2.72$ ./blender
connect failed: No such file or directory
Read new prefs: /home/yves/.config/blender/2.72/config/userpref.blend
found bundled python: /home/yves/Downloads/blender-2.72/2.72/python
fake_module: addon missing ‘bl_info’ gives bad performance!: ‘/home/yves/.config/blender/2.72/scripts/addons/overwmat.py’
fake_module: addon missing ‘bl_info’ gives bad performance!: ‘/home/yves/.config/blender/2.72/scripts/addons/removemat.py’
fake_module: addon missing ‘bl_info’ gives bad performance!: ‘/home/yves/.config/blender/2.72/scripts/addons/sendmat.py’
mesh_vertex_tools.py: new version loaded!
Error: Not freed memory blocks: 2

Blender quit
[email protected]:~/Downloads/blender-2.72$

In this part, I have manually accessed the blender folder without sudo, as user yves. I did not have to use ./ to run blender like above when I did run it as sudo. you can see that the process is the same and I got access to CUDA as it should.
However if I do not start blender as sudo in the first place, then there is no way to have cuda activated.

===================================
I don’t know if the ubuntu ommunity is concerned by this or if blender devs can provide clues as to how to solve this situation.
Also does other users are having similar issues? or others?

For cuda install nvidia-modprobe.
For the shortcut use this file and search on the Dash then pin it to the launcher.

[Desktop Entry]
Name=Name Displayed on Laucnher
Comment=Launcher Description here
Exec=Location of executable here
Icon=Location of Icon here
Terminal=false
Type=Application
Categories=Category here

#Save file in /usr/share/applications as ________.desktop

I just got this answer from the askubuntu.com regarding the issue I have with installing the builbot blender releases:
It seems that ubuntu is checking continuously on the way apps are working and in the cases where they are ‘errors’ generated by an app, then the os will try to find what package that app belongs to and do an error log or other actions:

===================================

Answers active oldest votes

                                      up vote     3     down vote        
          
                  This happens because apport fails to see the parent package of the failed executable file. apport, which is Ubuntu's problem reporter, watches every problem in Program execution. 

When a program crashes, apport is triggered to find the program (It watches for the programs execution constantly, unless you disabled it) which indicates Abnormal program termination. It finds the executable file which has crashed and search for the system for package that includes this executable file. When It fails to find a parent package containing that executable file, (in dpkg’s database) It shows that error, saying “The report belongs to a package that is not installed.”
For example: I uses a program for my Wimax modem, called wimaxc (which is not installed by any package manager). It sometimes fails and apport also fails to find the parent package of the executable file, /usr/bin/wimaxc, hence , It shows that error message.
To find the parent package of an executable file: If you want to find the parent package of an executable file, for example /usr/bin/gnome-terminal type the command below in a terminal:
dpkg -S /usr/bin/gnome-terminal
It will give you an output similar to this
gnome-terminal: /usr/bin/gnome-terminal
Here, gnome-terminal is the parent package of the file /usr/bin/gnome-terminal.
Note: Whenever you installed a package, it is listed in the dpkg’s database. So, if you use a program, not installed by the package manager (such as apt-get, synaptic, aptitude or Software-Center), apport will always fail to find the parent package, when it crashes, because their is no parent package

===================================

thanks I will try it now.;

Moved from “General Forums > Blender and CG Discussions” to “Support > Technical Support”

To add and maybe close this question, a new update came on ubuntu 14.04 from Nvidia regarding openCL driver. Since the installation of that update I can run blender directly from its location and have CUDA working again. So that seems to have fixed that problem. Left is the question of shortcuts that don’t work. I have tested @ramboblender’s sugestion but the shortcut does not work. One clue is that when one right click on it, a pop up windows proposes actions and at the top where we should have ‘run’ we have ‘open’… So still an issue here…
Reading on the web in forums, somebody was talking about symlinks that were not properly setup with rights! I could not find out more on that…

The file should look something like this.

[Desktop Entry]
Name=Blender
Comment=3D Program
Exec=/home/user/Downloads/blender-2.72-93c4ba7-linux-glibc211-x86_64/blender
Icon=/home/user/Downloads/blender-2.72-93c4ba7-linux-glibc211-x86_64/icons/48x48/apps/blender.png
Terminal=false
Type=Application
Categories=Aplications

#Save file in /usr/share/applications as blender.desktop

It is not meant for you to right click on it.

You shoul save it in /usr/share/aplications. After that you can search on the Dash for Blender and pin it on the Unity launcher (if you use Unity , it won’t work as desktop shortcut).