Issues with failing render after a few frames

For some reason my render of my current projects fails after rendering 5-10 frames. I am using cycles, have tried experimental and supported. I have tried many variations of sample size at 256x256 tiles and cannot find anything specific in my scene that would be causing this issue…

I have render on Optix with a rtx2070

I have also tried CUDA with 2070 and 1060 checked.

I am attaching the .blend file below if anyone can please help.

https://drive.google.com/file/d/1cg6OjQ5zyL_Ox7_6my0Z0iRgTUfqJqkb/view?usp=sharing

Just a thought, have you tried only cpu?

Yes it fails even faster in that case.

This scene looks like it started in 2.79 but it won’t now open in 2.79b. Have you tried rendering frames and then later putting them together in the video sequence editor? I think this is common. I havn’t seen what would cause the problem yet.

I opened a blend file of the car in the scene I downloaded online and used it as a basis of building around the rest of the project. I’ve been using 2.9 the whole time though. I also tried making a new file and appending, yet nothing is working…

Yeah, not really sure what to recommend. When I render out frame 15 to 19 I pretty much get a black frame… Here anyway. I think it might help to render out frames as I mentioned though. Maybe you can avoid frames that are not rendering or pinpoint the problem.

That frame should be blank it begins facing the phone object which would ideally have a video playing but I can’t even get it to render that far. What’s weird is it will render far later parts of the animation that should require more intensive renders. I.E. smoke and fire sims etc.

Another issue is rendering out frames that way would take weeks because the TVs a 650 frame animation. But thank you for taking time and being helpful!!

Your welcome. I rendered the first 49 frames with no problem here. Another thing that might lead to a clue is opening a console and running blender from the command line, you may get some message there.

Ok I will do that when I get home. I don’t understand how the rtx2070 can’t do this. I feel like I’ve done far more render intensive scenes.

I am also experiencing the same issue with an RTX 2080. The scene frame renders fine as a single image, however, when rendering an animation, it only renders x % of Tiles.

I’ve rendered far more complex scenes in the past using FLIP Fluids.

That’s a bummer to hear. It’s not a super complex project but I’m on a timeline and don’t want to redo the whole scene. Is there any workaround anyone can think of?

“Frame-per-file rendering,” e.g. into MultiLayer OpenEXR files, at least gives you the consolation of being able to resume where you left off. I agree with trying the command-line, but also, using your chosen operating system’s “event log viewer.” When an application goes hard-down like this, it will usually leave console messages and possible tracebacks – or at least the instruction-address where the fatal exception occurred.

It is highly unusual for any modern application to outright “die.” They ought to be able to “trap” any exceptions that occur, and respond more-gracefully. (Even if they have no alternative but to terminate, which is extremely rare.)

Things to think about now:

  • Do any other renders succeed?
  • Do you have any previous versions of this project which didn’t crash?
  • Are you keeping a “captain’s log” of your work which might help you identify a particular recent change to the project which might have introduced this problem?
  • Do earlier versions of Blender also have this problem?

For anyone in the future with a random issue like this, it didn’t work in 2.92 or 2.9, but worked with 2.83