Issues with Processor Speed

Hey Gang,

First off let me say this Forum ROCKS. I have done more with blender since finding this spot then ever before. I do have a little problem though.

I have finally created two …realitvly desent characters in Blender. (Now they are not Pixar quality but still) The viewer window began to get real LAGGY. I did not think that there were that many vertexes. (I switched to box view and it worked a little better but was still lagy)
I guess I haver several questions

  1. the only thing that is not up to snuff is my video card, will that effect blender OUTSIDE of rendering? Would a new graphics card help my “editing of blender” or would it only help speed of rendering?
  2. I have a dual processor is there anyway for Blender to dump on both processors for parrallel calulations? (so far I am running 60-80% on one and 20-40% on the other. ) (So it seems I have more cpu available?)
  3. If i use the “Set Smooth” button do I need to use sub-surfaces? I have not been able to see a difference once I hit Set Smooth.

If any of you have any ideas please reply. I created a simple scene and …it takes about a second to move from one frame to another on the timeline. I am not sure what will happen when I try to put a house on it.

Black Manta :Z

PS I have a gig of Ram. so I don’t think that should be a problem.

Hi, and welcome to the forum!

  1. You’re video card (at least to my understanding, please correct me if im wrong!) is only used in the realtime, i.e. the “editing” part, as you call it, and rendering is done by your CPU only. So yes, upgrading your video card should help a lot with editing your meshes in blender.

  2. To my knowledge, blender does not support dual processors yet, but YAFray can.

  3. Use set smooth with “autosmooth” switched on. this enables you to choose at what angle the set smooth function decides to whether to smooth the corner into a curve or to leave it as an edge. You do not need to use subsurf.

If you are having trouble with your scene slowing down, you can always move unnecessary stuff to another layer when editing.

thanks I guess Ihad it backwards…Well until I can get a new video card I will won’t complain too much. Thanks again

Black Manta :Z

PS That hidden layer is a good idea I accidently stumbled onto that concept while I was removing something from the scene I will remember that. Thanks a lot.

Just to note, Blender does support multiple processors. It’s under the render settings – make sure the Threads button is pressed.

Whats your curent graphic card? If its ATI, than this may be a driver problem.

It is an on board intel…(I should look for an updat in drivers for it) Yeah I know it isn’t very good.

THanks for the hint about blender that will make rendering easier.

PS what is YAfray and where do I get it? (Is it a plugin for Blender?)

Yafray is a rendering proggie which is easily integrated with Blender. Check here for yourself

What kind of video card do you have?

Did i understand correctly, that you are using only subsurf to get nice round geometry? You should always youse a mix of subsurf and setsmooth in this case. Like Subsurf level 2 or 3 and setsmooth. (that will make a cube to a nice round ball)
What subsurf level are you using, usually? Beginners often set it waaaaay to high, to get smooth geometry, because they don’t know about the setsmooth button.

BTW: for setsmooth you have to either be in object mode when you press the button, or in edit mode with all vertices selected.

Yeah that is what I have been doing sub-surf around 1 or 2 3 on special objects. Then I use setsmooth. Ijust wondered if I had to use sub-surf.

thanks again
BlackManta :Z

You really should say what kind of video card you have so we can be sure that’s the problem.