Issues with smooth shading on human model

Hello everyone, hope you are all well.

I’m currently working on a male human mesh for a game. The style is low-poly, so I’ve made a sort of medium tier low-poly male model (just under 30K tris), but I’m having some issues with the smooth shading. I didn’t really think it was an issue until I exported the model to 3D coat and noticed that the shading artifacts stayed, and continued to affect my textures. :frowning:

Here are some pictures of the main offenders (above all else, the head is the most important part for me, i’m not particularly worried about the rest of the body.) As you can see, the shading is really annoyingly blocky around the nose and eyes.



I’ve tried googling my problem, but it’s usually about non-organic models and is fixed easily. I’m not really sure what to do. Adding another subdivision level fixes it somewhat, but then the model goes up into 100K tris, which is not something I really want. Maybe as a last resort.

I’ve attached the blend file. Any and all advice is extremely appreciated, because this issue is bottle-necking my workflow. Thanks for taking the time to help. :heart:

BlenderArtists.blend (3.21 MB)

What you might want to look into, is to really check out the quads that bridge between the cheekbone and nose. The quads are being bent at 45 degrees, which causes them to split the shading into triangles. To fix this, you need to reconsider the edge flow so that they bend up the nose at a straight angle.

I think it’s easier to illustrate with a mesh grid. They are the same density. One is rotated 45 degrees so the quads will “break” when deformed.

after you subdivide, either apply and manually add triangles, or try a triangulate modifier. “J” will create a cut between two points. in the edges menu(mesh menu), theres a rotate(maybe flip?) edge if the cut is the wrong way.

since this is a game, it will get triangulated by the engine. at that point you have no control over which way the cut goes.

Oh! I didn’t know it did this. Thanks for clarifying. Although, I’m still having trouble trying to fix it still. I’m not really sure, maybe I’ve just been working on it too much tonight and having a foggy moment. I can’t help but noticing this happening quite a lot over my model. Even where a 45 degree deformation isn’t really occurring. Is there anything else I should be considering here? I’m not exactly a pro at topology (as you’ve probably already seen), I’ve just been using a simple google search of “facial topology” whenever I needed a reference.

@Daedalus, I’ve tried triangulating as well. I’ve been trying to leave it as the last step because working with polys is just easier to see. It does help, but only slightly. I’m starting to think it might just be how the smooth shading behaves at this kind of density. Not sure :frowning:

Quadrilaterals and n-gons can be non-planar and/or concave, which is a problem with automatic triangulation.
non-planar https://blenderartists.org/forum/showthread.php?325921-Shading-Issue&p=2569443&viewfull=1#post2569443
concave https://blenderartists.org/forum/showthread.php?337775-Simple-modeling-question-Triangle-stays-when-moving-vertices&p=2653061&viewfull=1#post2653061

The non-planar example shows more geometry as a solution but when the structure flow doesn’t follow the forms, it’s better to fix the flow. The sternocleidomastoid muscles on the neck you have there are a good example: the flow on them should be similar to a cylinder, now the quad grid just goes over like there were no form change.

Non-planar quads are normal. Severely non-planar quads cause a problem.

The shading is controlled by the normals so an alternative way might be to bake a normal map from a clean surface. Since it’s for export, would need to triangulate the target geometry before baking, so that the triangulation doesn’t change the underlying geometry between the applications.

Wow, that makes a lot of sense. You’ve simplified something that has eluded me for weeks in 5 minutes. So maybe I will work on my edge flow a little more, and then apply this knowledge. Thanks so much @JA12, always there to support us when we need!

It’s possible to flip the triangles in the trouble areas after triangulation, but that doesn’t always help.

You might be reading a bit too much into Blender’s solid mode shading. The specular shader (put on top of the phong) is made to really accentuate topological differences, but it sucks for low-ish poly organic objects. Think of Blender’s solid mode like a critical shader that’s extra mean.

Also, you using a viewport specular hardness of 50 isn’t helping. For organic forms lower it to 20 and reduce the specular color to a dark gray.

And for goodness sake, change up the default OpenGl lights! Get the “Quick Preferences” addon and try the Softblend preset.

If you want more proper shading, I’d start by adding a simple shader in node editor and set it in material mode. The diffuse shader will completely eliminate the speculars, but shading issues due to topology will still be visible.

Another thing to consider is correcting the shading by normal maps. The only problem with that is it doesn’t always translate well into games.