It crashes when i try to render pls help

Hello everyone i’m new to blender whenever i try to render something like rendering an image in blender my whole pc crashes my pc specifications- Device name user-PC

Processor Intel(R) Core™ i3-4130 CPU @ 3.40GHz 3.40 GHz

Installed RAM 4.00 GB (3.89 GB usable)

Device ID 9EC8CDD3-E87D-477B-8D21-D6528311DCC2

Product ID 00330-50000-00000-AAOEM

System type 64-bit operating system, x64-based processor

Pen and touch No pen or touch input is available for this display

do i need to buy a new ram or graphics card or something? And im running blender latest version at the moment
blender at the moment when it crashes

I’m running a i3-3220 with 8GB under linux. I assume you have windows 10 ? (w7 isn’t any longer supported)… 4GB is a bit few for windows anyway…
Can you render when you set the image dimensions to 320x200 for example?

hmm yea like rending small images work but if i try to do something big my pc crashes but idk what to do should i buy a new ram or graphics card or something?

Did you read my post? I use the i3 intern graphics only and 4GB is not much while doing any graphics app.
It also depends what you want…
Did you have a look at the system monitor? How much memory is shown as free? (And you to have sapce on the disk dor swapping). If you give not much infos, how should anybody give advice?

Hi Nishat,

It’s helpful if you include OS details and Blender version.

Memory requirements for Blender is very dependent on the scene. There are a number of strategies one can use to lower memory usage. Like using lower res texture images, turning on “Adaptive Sampling”, reducing mesh density, etc… Also, upping the PC “Virtual” memory can help (this can benefit your system ram and GPU “virtual” ram also - at the expense of speed - but at least it runs). Device drivers might also be an issue. Make sure these are up to date. See a previous post on this which may help with that:

Also, if you are using Windows you can ensure all unnecessary apps in your “Startup” are disabled. Use the “Task Manager” > Startup tab to take a look at these. Right click to Disable. Just be careful not to disable anything vital. I’m assuming Windows 10 here though. Disable unneeded Services also can help (but again make sure it’s not a vital service). As Okidoki mentioned make sure you have ample space on your hard drive(s), especially if you are using any “caching” or simulation type of stuff.

Naturally more physical RAM or new video card with more VRAM would help immensely if that is a option. I know it’s very tricky getting one’s hands on new hardware at a reasonable price these days. So hopefully the above options work for you.

Cheers and stay safe!