I've Botch Something In Settings

Hello, I’ve been getting back into Blender after a long hiatus and was following Andrew Price’s donut tutorial when I apparently screwed something up.

I’m working on an older Win 7 machine with a 16 gigs of ram, an i7 4790K and a 6 gig nVidia Geforce 1660 card. Blender version 2.91.

Now, I had actually done the tutorial once and finished it, and everything was fine. I decided to do it from scratch again to try and ingrain some of the processes.

So I got as far as making the cup and saucer when I notice that I was getting ambient light in the Cycles preview in the Layout tab. It was also overtly bright. When I hit F12 it rendered normal, but in Layout rendered view it was overtly bright and had an ambient skylight cast.

So I futzed around with settings, not knowing what I’m doing of course, and hit F12 and render was normal, but when I went to rendered view in Layout, it rendered blank and got and error message that read:
Camera Perspective
(1) Scene Collection | Camera
OPTIX_ERROR_CUDA_ERROR in optixDenoiserComputerMemoryResources(denoiser, rect_size.x, rect_size.y, &sizes) (device_optix.cpp:925)

So I hit F12 again and also got a blank screen and an error message the read:
Frame:1 | Time:00:00:49 | Mem:979.88M (Peak 1162.16M) | Failed to create CUDA context (illegal address)

This is weird because I don’t have Optix activated in preferences.

If I restart Blender I could initially get a render out of F12, but as soon as I tried Cycles rendered mode in Layout the whole process repeated. I also noticed in the initial F12 render that anything outside the live area was rendered black.

In the backup files I managed to find a copy that was still working but had the ambient in Cycles view. I noticed if I turned the LookDev render off by setting the Strength to zero, the Cycles view in Layout was normal again, but I had no LookDev mode.

Opening up the first, finished tutorial, everything was fine. So the hardware and Blender are working properly. I obviously managed to accidentally change some setting, and needless to say, I have no idea what I did. :smiley:

So if anyone knows what I botched up, please let me know, as it’s brought this project to a halt.

Thanks for any help with this.

I am not sure what all your problem is , but this bit : if you click the cycles viewport icon you will see 2 options, scene lights and scene world, it sounds like you have unchecked the scene world and your viewport is using the hdri from the the lookdev mode. Instead of turning off the strength of the hdri check the scene world option for the cycles viewport.

Edit: As for the cuda error did you change any “preferences”? Try resetting the defaults in the file menu
or choose render with your cpu instead of gpu in the render properties (at the top).
Good luck!

Thanks for your reply.

Yes, tuning Scene World on took care of the LookDewv mix on the version of the project that was still rendering in Layout render view. However I noticed the “empty world” beyond my “set” is black in the Layout render view, but not other views. I suppose that’s normal as I’ve mostly had the camera on my subjects and only recently aimed it beyond it, and of course there’s nothing out there.

As for the Optix error, I’ve checked the settings again and it is turned off, why it’s doing that is beyond me. The other file copies all work normally. If you would like to have a look at it, it’s too big to upload here, so I uploaded it to a folder I have online here (you may see a pop-up ad or tab, just close it down).

I would be interested to know what on earth I did to get this error, as I suspect I may accidentally do it again LOL!

Thanks again for your reply.

I have had a look at the file and it renders fine for me, both gpu and cpu, no optix errors.
My graphics card is worse than yours (GTX 650 TI) 1 giga

For me they all look the same plain grey default background.
Maybe you should check your Nvidia drivers.
Edit: my graphics card is not compatible with Optix anyway.

Well thanks for having a look. At least I have a version of the file I can work with and move on, but it’s a mystery to me what I did to it. There’s obviously nothing wrong with my system or Blender, as the other files work normally. I just hope I don’t accidentally do whatever I did to some other project file. :slightly_smiling_face:

So your F12 render didn’t create black outside of the live area? I think I remember Andrew mentioning something about that, either before or after the point I’m at in the second round of these tutorials. It has to do with some neutral ambient light setting. I must have accidentally hit various keystrokes thinking I was doing something else, and wound up where I did.

It’s amazing how easily you can mess things up when you don’t know what you’re doing. :laughing:

Thanks again for your help.

No normal grey.
If the other files work OK you could try opening one of the good ones and then open the bad one from the file menu. When you get the open file dialogue there is an icon that resembles a cog on the top left click it and uncheck the load UI. It might not work as it only applies to UI but is worth a try.
Or as last resort open the good file, delete everything then append all the objects from the bad one. Then save with a new name. That way you will have all the objects from the bad file but with the good ones preferences/layout etc.

Just to follow up on this, I started a new tutorial from scratch, CG Fast Track’s 2.9 Excalibur Sword tut, and started getting this error again in cycles (although so far he’s actually using Eevee in the tut).

So I just got fed up, uninstalled Blender, searched for all things Blender in my C: drive, deleted them, ran CCleaner and wiped out all things Blender in my Registry, and installed the latest 2.92.

Problem solved.

I don’t know what on earth I did, but it royally messed Blender up, and it was getting REALLY annoying. I probably could have reinstalled 2.91 and it would’ve been fine, but the new version is out so I just installed that.

So if anyone should post a similar problem here, the simplest solution is to just dump Blender and reinstall it. Probably want to make sure any reference files are wiped out as well.

So, onward Excalibur. :slightly_smiling_face: