I've got a simple problem with the action editor..help? (picture included)

Try hitting the HOME key.

by “Home key” do you mean the view all button? tried that still nothing…

Yeah, that’s the first thing I’d do. But since that’s not the problem – have you somehow unlinked your Action from the Armature? The screen shot doesn’t show enough of the Action Editor footer to tell.

wait a sec…checking it right now…

oops…that takes a bit too long…anyways I just figured out the problem thanks :slight_smile:

For those who might run into it down the road, what was the prob, and how’d you fix it?

sorry for the late reply… here’s how I do it: actually I’m not quite sure what’s the problem but I got it fixed after clear parenting the eye from the head bone then I deleted the eyes… reply if you have read this.

here’s the pic of my current action editor (what’s it looks like now)

http://i924.photobucket.com/albums/ad87/nationundivided/problem2.png

as you can see the bone list appear on the action editor but if I hit the view all button (Home key) it still does not work…I have to select all of the bones manually for it to appear on the action editor list…any ideas why this happens?

repost: I’m suspicious with the key locks icon…could you check is there such icons in one of your models on action editor bones list? here’s the picture:

http://i924.photobucket.com/albums/ad87/nationundivided/problem2-1.png

I’m not sure if those icons were there before…
maybe I’m just confused…

Hmmm, it looks right to me, not sure I understand your explanation of the problem. The Lock icons are part of the Editor, so that you can prevent inadvertent changes to a channel that’s fully finished.

For the original problem, I don’t see how a parenting situation could affect how an Action appears in the Editor, but without looking at the file that shows the problem it’d be hard to be sure.

But if it’s working OK for you now, that’s always a good thing.

turns out the eyes wasn’t really the problem I had to select all my bones manually for the list to appear on the action editor…oh well…at least it works now…

I took a look at the Action Editor display options and can’t find anything that would re-create what you describe. AFAIK you should have a list of bones in the Action Editor for a visible Armature, without having to manually select all the bones. If you can post a .blend where the problem occurs it would be easier to figure this out, or at least to confirm the issue on another machine.

,

OK, it’s pretty obvious once I got a look at the .blend.

You have to set keyframes at least once per bone for them to appear in the Action Editor (I assumed that was the case in your first post – my bad). Without keyframes, there’s no Action – you can confirm this by unlinking an Action with keyframes – the bones listing vanishes as well.

Once you have set a keyframe for a bone, you can delete the key and the bone’s channel with stay in the Editor – it’s still an Action at that point,because the initial keyframe(s) have been set, even if they are deleted afterwards.

Using “Add New” creates an “empty” Action, containing no keys, so the channels (bones) listing is empty at that point – it still needs keys set for the bones to first show up.

wow a very thorough answer! thank you so much! :slight_smile: I’ll try it right now :smiley: