i've just compiled my first blender in ubuntu 64bt

but when i load big files /scenes into blender the build doesnt
utilize the 16gb of ram i have… … .im using ubuntu 64bt which
pickes up dat amount in system monitor

I think there’s a limit to how much memory a single process like Blender can use.

I haven’t heard that one before. What exactly is the limit and can you link us to the documentation please?

npm1 what is the scene you are using, and is there some indication Blender doesn’t have access to enough memory? Is there an error message?

nope no error, except when i rotate in 3d space it slows down, why should this be the case if i have 16gb of ddr3 ram, and 2 gb of gpu ram

Try using a different window draw mode.

User Preferences -> System -> Window draw mode.
gpu is used for the 3D view, (not system RAM), and this depends on the graphics drivers. There are some threads on the forum about some newer nvidia card drivers - please use search to find them.

What size of scene does this happen with.?
You say you built this version of Blender yourself. Are the problems only with this build, or with official releases also?

Is the RAM problem now solved?