Jagged edges in ortho mode for small scale objects

Hi!
Any idea if this is a bug or just an opengl limitation of some kind?

To reproduce it, create a tiny box around 1mm, then turn the view into ortho mode, and there it is…

No idea if it’s a bug but that’s a back-face culling problem.
Enable it and all should look good.

Distance too large between clipping start and clipping end. It’s a well known limitation of any z-buffered system: scene size and minimum detail size are at odds.

Thanks for the info, guys!