Jagged edges

As my modeling is getting more complex, Ive noticed while rendering,
that the edges are not as sharp - they’re starting to look jagged. How can I fix this to get the smooth edges back ? Does resolution have anything to do with this ? If so, how do I adjust it ?

Many thanks for any guidance.
heardc

Turn on OSA in your renderbuttons. That should help.

I’ll try that. Thanks so much

heardc