Jagged results from Gaea

I’m testing the free version of Gaea.
I’ve exported the mesh, which is quite dense.
I’m getting this result (the material doesn’t make any difference, the jagged lines appear even with the default material)

I applied the Shade Smooth, tweaked the auto-smooth and I’ve also tried Smooth Vertices to no avail.
Any idea?

Edit: For a moment I thought it was working but no, the jagged lines are still there.

Edit 2: Exporting quads and then adding a subd in Blender seems to address the issue.

I haven’t used Gaea, but It sounds like it had custom normals data. Next time try clearing that by going to Object data tab > Geometry data > clear custom split normals data.

Thank you, @zanzio

I’m checking and in the Geometry Data the default option is add a Custom Split Normals Data. I guess it’s due to the way the geometry it’s being exported.

Your thread was move to the other software section.