Jagged Shadow Edges in Blender Eevee

I’m experiencing some weird jagged shadows where the mesh is in contact with the eyes as shown here:
https://drive.google.com/file/d/1aDIZRFHcRnEVnJTfcjMPL9LNhLOKMaB9/view?usp=sharing

I made sure to increase the Cube size and check on Soft Shadows under the Eevee settings, why am I still getting this issue? Please help. :frowning:

Problem solved, I adjusted the Bias under Contact Shadows for the light settings. :slight_smile: