Jagged shadows

Hi, I’m doing some experimental renderings of various simple objects sitting on a white plane, and am using the internal blender engine and have set oversampling to 16. On rendering, the objects have smooth edges, but the shadows while blurred, are still definitely jaggy.

Can anyone help with this?

Spot and Area-Lamps have “Sample” value options that work like OSA and “Bias” in Buf-Shadows on Spots to ameliorate Samples.