Japanese 3D text. How to do it? Win2k please

I’m trying to get Japanese text into the model.

I’ve seen only one example of it – which Broken provided a screenshot. I’ve set up Microsoft IME, so I can type Japanese. I haven’t been able to get the text file to actually show the characters.

can anyone provide a step - by -step, including which text editor to use.

I understand I need to open a Unicode text file in the text pane and then convert it to a 3D text.

Wouldn’t it be less complicated (I’m not saying easier, since this involves more work) to use a big image of the characters you want, then model the characters based on that? You know, kinda like the Working Example for Curves, in the Manual. That would allow you to use the same model if the machine you’re working on doesn’t have Asian characters…

/ $0.02

No, you need to use the special button in tuhopuu3. Here’s a quick step-by-step on Windows XP, keep in mind this code is still in development by Rob and Mika, so things could change (for the better of course, I hope :slight_smile: )

You need a recent copy of tuhopuu3 - get it here in the blender.org testing builds forum.

First save your unicode text file. You can do this in notepad, make sure you choose UTF-8 as the encoding.


Then start blender and add a text object. Click Open Font, and load up a Unicode capable font (like Arial Unicode MS).


Then open the ‘Char’ tab, and click the little button with the text icon (tooltip: “Load Unicode text file”). Navigate to and select the text file you just saved.


And there it is:


Gee, I would be really busted without this tutorial (and tuhopuu3 version of course). In a middle of project it just occured that inserting special (polish) ascii characters in standard 2.37a is not possible. :o

This is a MUST BE in next version of Blender, I didn’t even realized that Blender has gone that far (2.xx version) without that feature.

Anyway, THANK YOU for this tutorial (and tuhopuu3 software available)


I was just wondering if any of the new versions of Blender are supporting international characters yet. I’ve tried tuhopuu3 on my mac, but didn’t have any luck importing Persian (a bit like arabic alphabet) text…

Anyone know if 2.41 is supporting this yet?



Yes, those unicode text capabilities came in version 2.40, so yes they’re also in 2.41 :slight_smile: The panels may not look identical to the descriptions above, but they’re there. I have no idea if they support persian though, or right-to-left writing. In any case, all the work that’s been done on it for the time being is already released.

It sort of works… But it doesn’t get the character order correct - it tries to write it left to right, which means the characters then get connected together wrongly… Oh well - close but no cigar!

Just for the record:

I used Blender 2.41 for Python 2.3 on a Mac OS X 10.4

Using TextEdit:

I used a font called “nesf2.ttf” (the first font I tried “Geeza Pro” didn’t work - I guess it doesn’t like unicode).
I saved the text into a text (txt) file using Unicode UTF-8.

Then in Blender -
I added a new text object, deleted the default text that appears, and went to the editing button (F9), on the Font tab, I clicked “Load”, and loaded my font (had to search a bit using Spotlight, as my fonts are littered i several different places), the nesf2.ttf font was in /System/Library

Then clicked on the “Insert Text” button, and there it was - albeit not quite right.

You can use Inkscape and save the Japanese text as SVG and then import that into Blender. This will work on all platforms and standard blender 2.41. It should even work for older versions of Blender.

So first you get Inkscape and write some text.
Select the text and using the text and font dialog in the text menu, pick an appropriate font.
Convert this text object to a path in Inkscape using object to path in the path menu.
Export this as a plain svg, not inkscape svg.
Then use the svg2obj script from here:


Blender’s internal import (still) doesn’t work very well. Make sure to save any work because Blender’s Python implementation is sometimes unstable. It crashed the first time I tried to import a test svg tonight for example but it worked fine the second and third times. The crashes are quite sporadic so beware.

I suggest using the scale on width option too when the dialog appears. If you choose as is, it doesn’t seem to work.

I didn’t have any Japanese style fonts so I used one with musical notes: