Jittery cube on changing view


(Jon12345) #1

I am on my imac, which has a nice fast i7 processor. However, when I hold the middle mouse button and move the view around, the cube is very jittery, almost as though it is showing two cube positions at once and very rapidly moving backwards and forwards between the two. Any ideas?

Thanks,

Jon


(Daedalus_MDW) #2

sounds like you’re orbiting around a distant point, or working with a large scene. these are the settings i use, and i find them very friendly.



(Jon12345) #3

Just tried your settings and no difference. Could it be something to do with the folder Belnder is in?

Its in Downloads/blender-2.78c-OSX_10.6-x86_64 and to run it, I just double click on Blender application file in Finder.

Edit: Put video of what’s happening as attachment here. Moved blender folder to applications folder so its not that.

Attachments

blender video recording.screenflow.zip (7.04 MB)


(Thies Schulz-Holland) #4

What graphics card is in your machine?
AFAIK the iMacs use notebook-class graphics cards: Might be some kind of screen tearing.


#5

I’m on OS X too (currently 10.9.5) and I also have this issue from time to time (very seldom), I can not say whether the conditions are those that Daedalus_MDW pointed out, which sounds very plausible;
what I can tell is that I have always stored the Blender folder in many different folders without any problem.
My settings differ from his in the fact that I have activated “Rotate Around Selection”, I do not know if that matters.

paolo


(Jon12345) #6

I have a NVIDIA GeForce GTX 675MX 1024 MB. Isn’t that a high end card?

On my PC, I have a far lower powered graphics card that is 15 years old and that works fine.


(Thies Schulz-Holland) #7

No, I’m afraid it isn’t.

a)
It’s a notebook graphics solution. The iMacs are not big enough to fit a desktop graphics card. So Apple uses notebook hardware, which is smaller and produces less heat, but also offers much less performance than its desktop counterparts.

b)
It’s five years old. So, it may have been a high-end chip in 2012, but not according to today’s standards.

Unfortunately I was not able to play your screencast - I’m on Windows/Linux machines and have yet to find a video player that can handle that SCC file.

But make sure to experiment with the VSync settings in the nvidia driver: Is it off, then turn it on. Is it on, try turning it off. Without seeing the effect, I’d still say this sounds like a tearing/screen refresh issue. Changing the “Window Draw Method” in Blender’s user preferences might also help.


(Daedalus_MDW) #8

or it could be the mouse tracking.

my laptop gt 755m works perfectly for all things blender.


(Jon12345) #9

Its as though the cube is in two places at once and it keeps moving back and forth between these two positions very rapidly, like 10 times a second.


(Daedalus_MDW) #10

i dont know how drivers work on osx, but are those up to date?

i guess its time for a bug report. make sure you try multiple blender versions and add your findings to it.


(Jon12345) #11

Just to be clear, I have noticed that you also get two cameras, grids etc.

I assume the drivers on osx automatically get updated. I am on OSX Yosemite. Its not the latest but I can’t upgrade as then my Parallels software wills top working,


(jensverwiebe) #12

In the past this was often caused by “continous grab” feature. Check in prefs if its activcated. ( INPUT-> mouse, first checkbox )

Jens


(Jon12345) #13

@jensverwiebe, you found the answer! Works perfect now. Thank you so much!! I knew my iMac could cope as its far newer than my 14 year old PC. :slight_smile: