Joining mesh to armature crashes Blender

As the subject says, every time I try to parent my mesh to my rig, Blender crashes. There are no keys or actions on the rig, and I even tried deleting all vertex groups in the mesh. Same result in 2.25, 2.28c, and 2.3. The only unusual thing about the rig is that it consists of three armatures CTRL+J’d together, and one of them is rather old (as in ‘from the dawn of armatures in Blender’ old). Even so, I’m not sure if that would have any effect anyway.

Any ideas? I think I’m going to paint textures for a bit now, so I don’t pull all my hair out…

-Daniel Huddleston

Does this happen every time you do it?

i.e. If you create a fresh new scene, create a mesh object, create an armature object, then parent them, does it still crash?

Broken: If I create a fresh scene, yes, I can parent two objects, no problem. But I was actually just heading back over here to update the previous message: in the affected file, I noticed that I can’t parent anything together without crashing–a box and plane had the same result. I’m going to try pulling the model and rig into a fresh file now via Append. I’ll post again in a minute when I see the results.


And it worked. I’m sorry guys…this is two nights in a row I’ve been pulling my hair out over something, and then I post here, then fifteen minutes later figure it out. I’ll invest a little more frustration in future efforts before posting again.


That’s ok, it still shouldn’t be crashing though! :frowning:

Could you perhaps post the offending .blend to try and pinpoint the bug?