joining meshes

I have a quite typical task, I have mesh head and torso, so now I’m connecting them together I chose edge loops from corner och head and neck joined them together. But…even I have tried to smooth the angle , which I succeded, and smooth the vertexes in smooth line, even so the head and torso seems to be somehow separated it has sharp angle in connect line and when in object mode their tone differ little abit.I used ctrl+J to join those in first part. seems that I miss some command to make them as “one tree”


I assume you just snapped the verts to each other to join the two parts of the mesh, but did you remove doubles also? Until you do that it will still see it as two separate parts, thus smoothing wont work correctly.

To get rid of the black lines, just select everything in edit mode and hit Ctrl+N to recalculate the normals.

ok, I did recalculate normals and that did help, but I didn’t earlier snapped vertices individually, I chose edge loop from nech and head and did join. So as I tried to remove doubles with several smaller and larger settings there were no doubles. and the stripe stays in editor mode but nothing at rendering where it seems to be correct. I have to try from beginning some savings before this point to focus in removing doubles.

solved: I think this solved I had to choose more widely those faces for normal recalculation than couple of rows.