joining objects screws the vertex groups up?!

So I have this nice little rigged up santa. manually made all the proper vertex groups, and all is well.
Thing is, I made them as seperate objects, and because it wouls be easier to select stuff, I didn’t bother to join them beforehand.
But now that one side is rigged well, I’m trying to join all the pieces together and afterwards, just copy the weight to the other side.

BUT! when joining, all the vertex groups act like crazy! I thought weights would get added to the existing groups if they were there, but they do not, Instead fingergroups contain pieces of the shoulder and arms, the lower spine also has parts of the arm and/or head/neck etc etc…

Does anyone know a fix for this?

I don’t know what the hell is going on… blender all of a sudden messes up ANY vertex group, trying more files,… wtf? tested and tried rigs/objects all of a sudden also jump all over the place!!! I’m gonna reboot the pc just in case…


Based on a quick test, it appears as though if 2 objects have vertex groups by the same name, they will be added to the same group when joining - order of selection doesn’t appear to make a difference. If the groups are named differently, then they just get incorporated into the joined object.

Could you problem come from using default vertex group names such as Group, Group.001 etc?

Best of Luck!

no that wasn’t the problem, blender was acting really weird, once I tried to join meshes, or mirror weights, all the groups got randomly shuffled. I’m quitte certain that’s a bug by now.
I rebooted and redid all the groups from scratch, first joining everything into one mesh.
reboot=>problems fixed…
You can see the result in this thread: