Joystick Sensor Compatibility

I’ve tried the new Joystick sensor in Blender 2.37 on OS X (10.3.9) with a Logitech Dual Action USB game pad. This means I’m on Python version 2.3.

This combination isn’t working for me. Does anyone know if the joystick support is Windows only, or requires Python 2.4 or something?

I’ve checked my logs and all I’m seeing when I start up the game engine (press p) is the following:


Could make FSref to frameworks folder
Using Python version 2.3

I don’t know if that’s normal or not.

If you’re not familiar with the Dual Action, it basically looks like a PS2 controller. This is not strictly a joystick, though the interface shouldn’t be very much different. Anyone know if game pads just don’t work?

— EDIT —

corrected my statement that there wasn’t anything in the logs…

It should work on your current setup
try the example here.
http://snailrose.home.bresnan.net/example/

Hey, thanks for the reply.

I downloaded the example and unfortunately it doesn’t work. I tried firing it up on my roomate’s Windows XP box and it worked!

I peeked into the code and it looks like it’s calling SDL under the covers. Some cursory searching on the SDL forums turns up a whole bunch of nothing…

http://www.google.com/search?q=site%3Alibsdl.org+joystick+os+x

Doesn’t look like there are any known major bugs, but some other people have reported mysterious and apparently unresolved issues with Logitech controllers:

http://www.google.com/search?q=site%3Alibsdl.org+joystick+os+x+logitech