K-3D 0.2 alpha released


(Manuel) #1

K-3D is a good opensource 3D software.

http://k3d.sourceforge.net/

The 0.2 alpha is a candidate for the next to come stable release.

From K-3D mailinglist, by Romain Behar, a developer:

Gang:

many fixes this time including the major bug that
crashed tools.

Several improvements too, especially with FreeType2
plug-in.

Tutorial translation examples come with the package,
the first one comes in italian and french.
Note that the tutorials have to be in UTF8 for the
Win32 platform and ISO-latin for other ones. We’re
working on UTF8 support in Unix/Linux for next
release.

It’s time to submit bugs, improvements, translations,
documentation, screenshots, rendered pictures, example
scenes, etc.

Note that Aqsis 0.6.4 is out.

Win32 binaries for K-3D are on the way.

Cheers,

Romain

Please, help it! :wink:


(kino) #2

Ciao Manuel

really cool apps, maybe a little younger :slight_smile:
but really powerfull.
solved the problem with the disp map?

Kino


(Manuel) #3

Ciao :smiley:
After a several help message, the question is solved:
it isn’t K-3D problem…, but a simple shader peculiarity.

From RmanNotes:

http://www.accad.ohio-state.edu/~smay/RManNotes/WritingShaders/disp.html

Dealing With Smooth-shaded Polygons
Smooth-shaded polygonal surfaces present a special problem with displacement shaders. Although the smooth shading surface normals give the polygonal data a smooth, non-faceted look with surface shaders, the polygons are still flat and therefore displacement of surface points in a displacement shader returns the faceted shading.

With smooth-shaded polygons, N (shading normal) will contain the smooth shading normal and Ng (geometric normal) will contain the face normal. We can solve the displacement problem by saving the difference between N and Ng and then adding it back in after we calculate the new normal. The code fragment below demonstrates this:

point Ndiff;
.
.
Ndiff = normalize(N) - normalize(Ng);
P += P * Km * surface_mag * normalize(N);
N = normalize(calculatenormal(P)) + Ndiff;


Unfortunately I’m not a shading expert, and I can’t correct or add
the K-3D displacement shaders…

Do you know who can help me?

Ciao,

       Manuel

(kino) #4

Ciao
i have some problem with k3d (Linux Suse7.3) a
strange error with the fontid in the Hierarchic view
and cant show the cam view, i cannot reproduce the bug,
i tried with ayam 1.1 but i dont get the same result as you,
maybe a platform problem? Also LightFlow it’s a little buggy
on windows system.
When k3d work i will try to modify the shader and make some
experiment.

Kino


(MaceG) #5

YES! Finally got it to render!