kde 3.3 and blender's render window focus problem solution

after upgrading to KDE 3.3 I had some problems with blender render window… it didn’t always pop up as it should’ve been, and it didn’t have correct focus… it couldn’t be closed etc… if you have had similar problems, read on.

in KDE there is this focus stealing prevention system. I’m sure there is use for it, but in blender it gives user a hard time with blender’s render window. you can’t get it to pop back up with f11, and also closing it cannot be done normally.

to fix it, you need to set personal settings for blender windowes.

  1. right click on window title
  2. select window settings
  3. select the the last option on the sidebar, “personal window settings” or similar
  4. add new setting (click new)

here’s the view what you need to fill in the first tab:
http://koti.welho.com/bsalmela/window1.jpg

and, here’s the other important:

http://koti.welho.com/bsalmela/window2.jpg
note: the word “ei mikään” in focus stealing system is finnish language… heh :). so translated that would mean “none”… it’s the first option in the dropdown… you can try other methods too, but disabling that seems to work for me.

note2: forcing the window type to be “normal” is not necessarily required… I think that was just left from my tests to find what is causing this behaviour :slight_smile: anyways, there are other interesting things too, browse them around and try… you can set blender always to open fullscreen, without borders, to a certain desktop etc… :slight_smile:

anyways, I’m happy. hope it helps others … if there are others sufferings this.

.b

thanks basse…

we both had this problem, and I thank you for solving this… :slight_smile:

thanks again!

KDE rocks!

/.Z