Key bindings problem!!!!

Hi All, total newbie, to this forum

Since I have upgraded to 2.48 then 2.48a when modelling or doing anything in Blender… the keys suddenly start to get mixed up! So CTRL-Z brings up the Save Dialog!!! CTRL-W becomes undo!!! and W becomes (wireframe/solid…) toggle and Z itself becomes (boolean options) - and so on!!! - they’re are lots of others

Just as suddenly, it fixes itself, but… then gets mixed up again at another time!

WHAT - in the name of sanity is going ON!!! :eek: :confused:

It’s NOT my w/keyboard! because, if I go out of Blender into Word, or any text editor then all is OK! Come back into Blender and all is not OK, key Bindings MIXED up!

I need to get this sorted as its making Blender pretty useless!!! and driving me mad - arghhhhaa! help! :mad:

Blenman

ok - it IS the wireless keyboard. Made by microsoft, so I blame them!!!

Maybe the bunny with the bass drum got you? Did you check the batteries?

batteries, singal strength are all fine -

This problem only happens in Blender though, not in any other app. I use which has key bindings! strange!

BM

er… it’s STILL happening with a USB Mouse and Keyboard!

when the problem occurs, which is at seemingly random intervals…

pressing abcdefghijklmnopqrstuvwxyz
I get this sequence: qbcdefghijkl,noparstuvzxyw so not all letters are getting mixed up

when I press the numbers
1234567890
I get these charcters
&é"’(-è_çà

This was done in Blender Text Editor window, when the error occurs!

Alt Tab to Notepad and everything is OK - back to Blender and the letters are still mixed up!

As you can imagine Blender becomes impossible to use and this is really annoying me. The error comes and goes randomly!!!

Has anyone heard of this happening before, any reasons that point to solutions!!!

I have been using Blender for over a year, on and off, and this has only started since 2.48 and 2.48a (but it also occurs in 2.45)

please help!

Puzzling. I would say that you must have the wrong zone (internationalization) of keyboard in Blender settings, but I don’t think Blender has settings for that.
…if it’s also happening in earlier versions of blender, perhaps it’s your B.blend (default configuration) file.
If so, you may be able to fix by deleting B.blend or, in blender, File > Load Factory Settings.

Other than that, no idea at this stage.

Check the internationalization of keyboard setup in your OS preferences as well.