Key Mapping issue

I have a quick question. With my mouse my middle mouse button is behind the scroll wheel instead of built in the scroll wheel so it is relatively awkward bringing my finger to it. It is usually fine but in blender the i pan the camera is opt mmb, then i move the mouse and it pans. Great. But I really don’t like moving my finger every single time i want to pan a bit, or rotate a bit. But when i go into the user preferences and switch pan to opt cmd lmb, it doesn’t work, what am i doing wrong?

If you only want to use the LMB for rotate, pan and zoom you could enable the ‘Emulate 3 Button Mouse’ option in the User Preferences / Input panel

Rotate = Alt+LMB
pan = Shift+Alt+LMB
Zoom = Ctrl+Alt+LMB

Note: Please use the correct support forum in the future. Moved from Blender Discussion to Support / Basics & Interface

I just switched from maya and i just can’t get used to the normal blender controls. Is there any way i can just switch pan from opt mmb, to opt cmd lmb? Also emulate 3 button mouse does not work for some reason. But i just want to switch pan to opt cmd lmb

Why are you creating multiple threads asking the same thing. STOP IT !!! Someone has to clear up the mess you are making

File / User Preferences / Input.

Set the shortcuts to whatever you want.

Sorry. Thank you for the help.

did you try the maya preset?

Ok i have the problem fixed. But I would like to ask another question while here. When I use two fingers on the trackpad it sees it as a trackpad instead of scrolling. How would i fix this?