Keyboard disabled when using Blender

Hi there! :slight_smile:

i’m stef (shtefh) from France, i’m a beginner with Blender, and so i was looking for a great forum where i can find help when needed, so i’ve just registered here…

I have a first question, and the title of my topic says nearly it all. When i use Blender my keyboard is disabled at some moments and i don’t know why (i have to logout from my session and login again)… I’ve read on the web that it could be a conflict between Blender shortcuts and my desktop(1) shortcuts. May be…

More details:

  • i use Blender under linux Fedora 17
  • i have a dual screen (don’t know if it’s important regarding my issue)
  • (1) my desktop LXDE http://lxde.org/

Do you know this problem and how to solve it?

Thanks for your help.

Ps: as someone suggested it to me, the next time i run Blender, i’ll run it from a terminal and redirect the output in a file to get the messages from the app; so i’ll post that log in the discussion.
pPs: hope my english is clear enough…

Hi, here comes the output from Blender when launched from a terminal:

found bundled python: /home/steph/Apps/blender-2.64a-linux-glibc27-x86_64/2.64/python
read blend: /home/steph/Dev/Blender/mnrh/mnrh.blend
Saved session recovery to ‘/tmp/quit.blend’

I had the same problem with my keyboard, and Blender doesn’t seem saying something about that…

If it can help anybody, i’ve solved that problem by removing the proprietary driver and installing the akmod-nvidia.

Some news about that problem (that is not solved actually), i’ve discovered that for an unknown reason my system decides at some moments (only when i use Blender) to set the keyboard on ‘slow keys mode’… :confused:

Some had a similar issue: https://www.google.fr/search?q=fedora+accessibility+keyboard+slow+keys

The only way to reset my keyboard to normal state is to open the Accessibility dialog (Parameters>Accessibility), and check then uncheck the ‘Slow keys’ checkbox.