Keyboard not making object move. Help needed. (Maze Game)

Hello everyone. I tried my hand at making a game (my first attempt). I followed the step by step instructions in the Maze Game Tutorial. However, when I went into Play mode, the ball dropped to the maze floor, and doesn’t move.

I am at a loss for why the keyboard doesn’t control it. The bricks are all linked, so it should…

I’ve uploaded a copy of my .blend file for anyone who wants to look at it for me.

Hmmm… Tripod is a pain. You can go to and then Right Click / Save As on the link I put on the page.

Thanks for any help.


I’m not too sure what the problem is…I downloaded it and tried and it works for the 2 directions you have keyboard sensors for.

Is your problem that the sphere isn’t going left and forward from where the camera is initilally located? If that’s the case then here’s what you need to know to fix it.

If you select the sphere then go into the object buttons (F7) and click axis you will see in which direction your x,y,z axes are pointing. Now if you then look at your motion actuators you will see that you have a force of 20 in the y direction linked to the up arrow key. The motion is as should be expected…the sphere moves towards the camera and not away from it as I’m guessing you expected. The same can be said for your motion linked to the left key in which you have a force of -20 in the x direction which moves the sphere to the right when looking through the camera.

Hmm. It still doesn’t work for me. I swapped the axis around (thanks for pointing that out for me), and still no motion when I use the arrow keys in up or side.

I realized I don’t have Python installed… Is that a necessity for the game engine? I don’t think I’m using any scripts…



I have since installed Python and it still doesn’t work. I’ve downloaded a bunch of the demo files and some of them work and some don’t. Its so odd… Help please!

BTW: I’m using a p3 500mhz laptop and Blender 2.35



Very weird… Just an update that everything works fine with the .blend file on my work PC. It must be something with my laptop…