keyed un-pinning in cloth simulation

Is it possible to “un-pin” a cloth in mid-simulation?

An application for this would be a flag waving in the wind which breaks free and is blown away.

The first part is a simple cloth simulation with wind and a subdivided plane, pinned at two corner vertices… which works fine.

Most parameters of the cloth simulation are key-frameable with “I”, but neither the pinning option nor the vertex group select box seems to be changeable during simulation.
I tried to change the weight paint directly, but those does not seem key-frameable either.

Any ideas? Thank you

Well it is possible to unpin a simulation but not with keying the pinning. You just simulate to the frame you want it pinned with ctrl + a then change the pining and continue the simulation from that frame. I can’t actually remember the steps and can’t check it now (writing from my tablet) but looking at the blender wiki site i think I presed “rebake from current frame” to continue with the simulation.

I wish it would be possible to do that with keying and do the changes automaticly during simulation.

Thank you for this idea. I had it myself, but unfortunately this option seems to be gone (v2.65 r53177).

If I cache the simulation to memory, the cache is cleared as soon as I change the pinning option.
As a matter of fact, any manual change of the cloth parameter will clear the cache.
You can change most of the parameter using keyframes, except pinning (hence my question).

I haven’t found a way to mimic the old “rebake from current frame”.

Ok, tryed it out with blender 2.66 testrealease. It’s posible but a bit hackish:

  1. alt-a to play the animation till you reach the frame to unpin if you overshoot scroll back.
  2. unpin and play animation again but stop before it begins to loop back to frame 1
  3. Press “Current Cache to Bake” to lock your simulation so that you don’t lose your simulation acidently.

Thats it! but like I said it’s hackish.

Success!

At first I was disheartened by the fact, that the blue line in the time line - indicating the presence of the cache - changed colour, but it worked…

Thank you.