I new to blender and is following Niel Hersig’s tutorial on making a submarine.
All is good until I reached the animation part.
I got the periscope animated and rotating. Then I tried doing the same thing with the rudder, but nothing happens. The keyframes gets highlighted, but as soon I move away from the keyframe, it forgets it.
I’ve tried deleting them and start over, but the same thing happens.
Does anyone have an idea of what I’m doing wrong?
Using Blender v 2.74

Not sure what you mean that keyframes ‘forgets it’. Can you post a .blend file? or describe more clearly with screenshots?

I think I know what you are talking about. I’ve come across this problem and spent at least 5 hours straight trying to fix it in my game. I think your problem is overloading the action actuator or graph editor. To solve this, animate the periscope and then create a new action editor instance for your animation of the rudder.


Try this…Set frame to 100 in timeline…Add a Cube and select it…Cursor in 3 d viewport…Press i and select LucRotScale
Now there should be a yellow marker in the timeline…Click another frame in the timeline…Move - rotate the cube…Cursor in 3 d viewport Press i and select LucRotScale…You should now see 2 yellow marker in the timeline…And the key is set.

Hope this make sense.


Thank you everybody for your help.
What I meant by forgetting the keyframe was, when I put in the value for the keyframe, go to another frame and then back, the value had disappered.
I was pressing I, then the value.
I properly should have read the text a little better though, as I was supposed to put in the value and then press I.
Sometimes one doesn’t see the forrest because of all the trees. At least that has been a valuble lesson and I’m very sure I won’t forget in the future :slight_smile:
But also, by using this site, I found people willing to spend time to help. And for that I want to thank you.
How do I mark this as solved?


Well, thank you for bringing this up: I’m having the exact same problem,
except it’s not enough to set the values, then press I:
Blender (2.69, 2.75) STILL forgets the rotations I set (to bones in an armature, Pose mode). :no:

In this particular case, I had imported a .dae (Collada) of a figure from DAZ Studio 4.8,
that had several frames of animation (frame 0: pose 0; frame 5: strike a pose).
All was well except the character’s eyes, which really just needed to be set
to 0 pose (Pose editor: select eye bones, Clear all transforms).
[That comes from a bug in the DAZ Studio to Blender Collada transfer.]

Because there was no intended relative eye movement from Pose 0 to Strike-a-Pose,
I solved the problem by going into the Dope Sheet, deleting the keyframes
associated with the eye bones, then “Clear all” in Pose Editor:
that modification (performed at frame 0) did stick, all the way to frame 5.

This still does not solve the problem:
what if I had wanted specific (and different) poses for the eyes,
because then I would have needed keyframes. :eek: