Keyframing is absolute crap?

When I try to key a helicopter with armatures to rise, no spinning of the rotors, the helicopter moves up, but the rotor goes slower and never catches up, even though I keyed them together. Also, the armature I am using to move the rotor is separate from the rest of it, even though it was extruded from the original armature. By separate I mean the body can be moved and the rotor wont follow.

parent the rotor armature as an object to the top bone of the helo body armature.

How do I do that? The rotor armature and body armature are the same object, and it wont let me parent a bone to another bone.

in edit mode, select the rotor bone, and then in the Armature Bones panel, select the body bone as the parent. In this example, the parent is the Stride bone.

Attachments


Thanks! Another question, though. How can I make the rotor spin in one continuous motion? If I keyframe it at a rotation of 360 degrees, it doesn’t move.

Rotate it 90 degrees, then use the curve interpolation and extend options or just edit the curve in the IPO editor
http://wiki.blender.org/index.php/Doc:Manual/Animation/Basic/Tools/Ipo_Curves_and_Keyframes#Curve_Interpolation

I tried messing around in the IPO editor, but there was nothing to move. I had inserted a key at 20 and a key at 80 and rotated it 5000 degrees, but the IPO editor was empty.
Edit: I tried what you suggested and there is still nothing in the ipo editor.